Installing Desktop version in kali linux

joplin
Directory is wrong for root user as its getting stored in /root/.joplin/Joplin.AppImage
I have been trying to install this app in Kali linux.I tried changing directory but when I am clicking on Joplin Icon its not opening anything.
joplin1
I tried running it manually but its giving me this


Tried running with --no-sandbox giving me this
jp
Any reference or suggestions are welcome.
Please help.

1 Like

Welcome to the community, @p3n7a90n. I have one serious question for you: Why are you running Kali Linux as a desktop installation? It is not being developed for that at all, as its primary usage is security testing and hacking. For that reason, it’s built to be used from an encrypted flash drive and loaded as a live usb so that when the user is finished, they can pop it out and it’s like they never were there.

If you do insist on using Kali Linux as a desktop OS, I would highly recommend installing Ubuntu or Debian instead. The amount of work required to get Kali to work as a desktop OS would basically make it Debian normal anyways.

Thanks for the reply.Live boot in kali linux is just one great option and it has nothing to do with the primary usage of kali and kali is based on debian.


I thought of using joplin in kali cause of my HTB(Hack the Box) Writeups.

Again, I disagree with using it as a desktop environment, but you do you. I definitely know your current issue is a duplicate issue that was fixed here.

Okk thanks for the link.Anyway I am using Kali in my VMware.

Do not get me wrong but people can use whatever they want as their desktops system. His issue is not Kali specific. Joplin has been having packaging related issues on Debian derivatives, that is the issue. You just old him to give up his system so he can go around the Joplin packaging issue.

2 Likes

No offense meant. The issue was Joplin related and is a known issue with Debian systems, just Kali as a Desktop environment could definitely offer quite a few more possible issues outside of what is known with Joplin since it was never built for that usage to begin with. Even the devs do not recommend using it as a desktop environment due to many of the changes they made that compromise the security of the system in order to provide its specialized usage.

I am not opposed to anyone who wants to use whatever they want as a desktop environment but also am pragmatic enough to know that certain Operating Systems are not built for certain tasks and Kali is definitely an edge case there.

1 Like


From Kali Official page

2 Likes

They definitely changed that for PR reasons. That used to be a terrifying “DON’T DO IT” type warning. I’ve been a Linux user for over a decade and have dipped into quite a few OSes and Flavors, and that one was definitely very opposed to anything outside of Live USB for a long time. I’m sorry for how I responded. Either way, thanks for correcting me.

1 Like

I have followed that link and I couldn’t see a solution for what I experience.

dantor@kali:~$ ./Joplin-1.0.179.AppImage
[10497:0312/200857.826042:FATAL:setuid_sandbox_host.cc(157)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I’m aborting now. You need to make sure that /tmp/.mount_Jopline0AIxA/chrome-sandbox is owned by root and has mode 4755.

I realize I forgot to sudo the command. With that, I have the same result as p3n7a90n
> dantor@kali:~$ sudo ./Joplin-1.0.179.AppImage

[11973:0312/201948.555559:FATAL:atom_main_delegate.cc(211)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.
Trace/breakpoint trap

What can I do, can you advise me, please?

The —no-sandbox wasn’t supported in 179. You’ll need to upgrade to 193 (the latest). You will need to be wary that once you upgrade, you can’t go back due to new encryption algorithms implemented. This mostly applies if you use encryption. If not, you may still have some issues going back anyways

I came across this thread yesterday as I was having issues installing it too.
Today I found this https://github.com/initinfosec/joplin-kali
I haven’t tried it as yet but thought it might help a few of you out.