Joplin-desktop not working in manjaro

Hello all,

I have been using Joplin ever since I installed nextcloud on my server. It has been working fine on my PC running Manjaro KDE until I have updated to the latest version 1.14.19-8.

It installs without errors, but when I try to start the app from the start menu nothing happens. I get more info when I try to run joplin-desktop from the command line. The following error appears:

/usr/bin/joplin-desktop: line 12: ./@joplinapp-desktop: No such file or directory

The /usr/bin/joplin-desktop file contains the following:


readonly joplin_dir="/usr/share/joplin-desktop/"

if [[ ! -d $joplin_dir ]]; then
  echo "Cannot find /usr/share/joplin-desktop/"
  exit 1

cd $joplin_dir

./@joplinapp-desktop "$@"

But there is no joplinapp-desktop file in /usr/share/joplin-desktop.

Any idea why this happens? It never happened before.

Thank you,


Managed to solve? I have the same problem here.

sorry for late reply! Yes it works now. I haven't done anything other than completely remove all versions of joplin and then I reinstalled the latest version using yay -S joplin-desktop and I opted to rebuild the package.

Now it works. I can't say I like the naming scheme thou. It makes more sense to me to name joplin the desktop version and joplin-cli the cli version, but that's another matter.