Import from joplin-flatpak

Joplin 2.12.19 on Manjaro Linux

How can i import a enex file in Joplin ? You write "open it in a terminal" but i installed Joplin from flathub. Is there another way more easy ?

@Titanet welcome to the forum.

I do not know where the advice to "open it in a terminal" comes from but if you are running the Joplin desktop client you use the "Import" menu.


This don't work, i tried already. Joplin don't know where my enex file is ! And no way to tell him !
Even if placing the enex file in /home/myusername/.config/joplin-desktop, the app don't open the file !!

Selecting the import option should open a file select dialog for the OS. Check that it has not opened behind Joplin. This sometimes happens with Linux.

No, no, no, there is no other window open behind Joplin, because Linux is far better than M$$$$, Ah Ah.
And i don't understand how this is possible, launch an open import action without asking for a file !!

This application should be tagged beta version !

It happens quite often on my Linux systems where the Joplin window obscures the dialog.

It does ask for a file. So there is either something wrong with the Flatpak app on your system or the app doesn't like your system configuration.

Do you realise that even though you are using the Joplin forum for support, the Flatpak version is not produced by the Joplin developers? It may be worth finding out who compiles and publishes the Flatpak and raise an issue with them.

Another option is to not use an unofficial third-party version and install the official AppImage.

This is rather rude when it is in fact you that is the problem here.

  1. You decided to install non-officially supported or distributed software
  2. You don't understand how that distribution method works

I strongly suspect your problem is due to Flatpak's sandboxing which intentionally stops them being able to see and modify the rest of your system.

If you still prefer to use the Flatpak version then you should probably either have a look at the docs I linked above or a helper application like Flatseal.

1 Like

Hello, i use Flatseal ! I know how to add some permissions to applications. Joplin don't ask to open a file when i want to import a single "enex" file !

If you have a working solution, so add it here !

Honestly I'm just getting confused at this point. Does the dialog box open or not when you click the "ENEX" option in import? If it does open then what are you actually seeing? It would help if you could put some screenshots in the post to help explain.

I already said that NO WINDOW open when trying to import from enex file. I have no screenshot to show you as nothing happen when i click "import from enex"..

Except you also said:

Hence why it is confusing. Have you tried with the appimage to see if it works with that? If it does then it is something you need to bring up with the flatpak maintainer.

You don't read my messages! I've already written that even when placing the file in the application's working folder, Joplin doesn't see the file. I thought Joplin would automatically open the file, but no!

I did read them, they made no sense, that isn't what Joplin does. Fine by me though, I won't read any more if that is your attitude, good luck!

Thank you for your patience. I'll find another way or wait for corrections.
Sorry for being a bit cheeky.

You need to do what both I and @dpoulton have suggested which is see if the appimage produces the same behaviour.

If it does then we have a problem with Joplin (or at least its integration with your OS).
If not then you need to report it as a problem to the Flatpak maintainer.

Edit: Can't replicate this using the flatpak on Ubuntu:

I use the Gnote application for my notes, how-to links, tests, etc...
I wanted to test another application to see if it would be more user-friendly. I've already tried CherryTree and wanted to see how Joplin works, I'm curious.
I'm not going to install a new Appimage version of Joplin because I don't have that need right now. I'll wait for the Flatpak version to work without having to twist my mind to get it to work!
Edit :slight_smile:
I have other Flatpak applications that work without any problems, such as FlighGear, Shortwave, Shotwell, even Steam.

Thats the point, you don't need to install an appimage, you just run it. If you don't want it later on then you just delete it. The entire point of the format is that it is self-contained.

And from what I can see the flatpak, although not maintained by the Joplin team, also seems to work.

I would not if I were you as it appears to be working fine at the moment.

@daeraxa has tested the Flatpak on Ubuntu and it works and below is Joplin 2.12.19 Flatpak running on manjaro-kde-23.0.4-231015-linux65 and the dialog appears as expected without any additional changes needing to be made to the system.


However, I have said all I am going to say on this matter so I wish you the best of luck in your search for a note-taking app.