Image Links to Dropbox Not Working

I'm a new Joplin user, though with experience in Markdown.

Manjaro Linux desktop client, Version 1.7.11. Android current to Google Play version update 3 Feb 2021.

I can't create an image link to an image on my Dropbox account. Pasting test images into the same document (Joplin logo and image from the welcome file) both work.

I have gone to Dropbox in Firefox and the Android app, copied the link to the image, pasted it into the Markdown image link. I get a broken link. If I edit it to a regular link, it works.

Synchronization between all three devices, Linux workstation, Chromebook is enabled and working smoothly.

Apologies if I am missing something obvious, but I have googled and searched the forums here and can find no solution.

what does the code look like?

Thanks for replying. All help is gratefully received.

The image link to the Dropbox image looks like this:
![Compass Rose](

If I edit it by removing the exclamation mark, it works as a link and opens the image in Chrome.

This link, to an image on a NASA webpage, works perfectly.

The Dropbox link is copied using the Android Dropbox app.

Does the Dropbox link work for you in browser if you're logged out of Dropbox?

Sorry, not quite sure what you mean.

It works as a hyperlink in Joplin, and it opens the image in a Web browser when I do. My Linux box is logged off and the Android app is closed.

I tried using an inline HTML tag, per Joplin Markdown Guide. That didn't work, either.

It looks like that URL isn't just image, at least when I open it in browser I get some popup and all sorts of other UI elements.
I suppose this is why Joplin can't embed it.

Change the 0 for downloading in the link to 1, than you get only the image.

![Compass Rose](

Awesome! It worked. Thanks.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.