I cannot get out of safe mode

Operating system

Linux

Joplin version

3.0.12

Desktop version info

Joplin 3.0.12 (prod, linux)
Revision: a64d6e3

Sync target

Joplin Server

Editor

Markdown Editor

What issue do you have?

Joplin, which had been working fine until I upgraded, kept asking me if I wanted to quit, ignore, or enter safe mode. I finally gave up and entered safe mode. Now I can't get out of it. Toggling safe mode in the Help menu does nothing. Clicking on the toolbar to disable safe mode and restart only causes the "quit, ignore, safe mode" dialog box to appear again. "Toggle development tools" works just fine.

Log file

log.txt (14.2 KB)

For me, the "disable safe mode" link briefly disables safe mode for some parts of the app (e.g. the note editor) before restarting the application. Here are a few things to try:

  1. Switch to a different note and notebook before clicking "disable safe mode".
    • If the issue is related to an interaction between the markdown editor/viewer and a particular note, this could fix the issue.
  2. Disconnect your computer from the internet, then click "disable safe mode".
    • If the issue is related to sync, this might help. However, sync still happens with safe mode enabled. As such, I think this is unlikely to help.
  3. Collapse all notebooks in the notebook list, then click "disable safe mode".
  4. In settings, manually disable all plugins, then click "disable safe mode".
    • This probably won't help — plugins should only be loaded on startup, and if safe mode is disabled. Disabling all plugins thus shouldn't fix the issue if "quit, ignore, safe mode" is shown immediately after clicking the "Disable safe mode" link.