Huge RAM usage

Hi @laurent

I encounter often the problem to run out on memory (see screenshot below). It does appear even if I have all plugins deactivatet and uninstalled.

At the moment I have the following plugins installed:

  • Agenda
  • repeating To-Dos
  • Markdwon table colorize
  • hotfolder
  • makeanneo
  • Backlinks to not
  • convvert to note
  • convert to new note
  • Spoler card
  • Table formater
  • afmonition
  • Toggle sidebars
  • markdown calculation
  • rich markdwon
  • better Markdown viewer
  • joplin Ocr
  • Linksystem

I did, as mentioned above, uninstall al plugins. then I did run it for some time with out the plugins. But after a week or so, I run in to the same problem again.

I do synchronize with onedrvive. So I copied all the file to the local harddisk, uninstalled joplin fully, including registry and purged all files too. Then I installed everything again, pulled the .enex files from EN newly in to joplin. But after some 14 days I did again encounter the same problems.

After that I did switch my NB to the Mac Book. Surprisingly I did had at the beginning the same Issues, but after three days it worked really well with no limitations. Even Syncing was as fast as never before on the PC.

So I did a test on Linux too, I had no problem at all there. It startet out of the box with lightning speed :slight_smile:

I then checked back on my NB. Happily I have two diffrent to test it out. Both are runing with 8 GB Ram, Intel 5 4Ghz.

On both Notebook I had the same result as on the screenshot bellow.

I do running the latest Joplin Version 2.7 on W10 and one on Win11.

Could it be, that there is a Bug on the Win version of joplin?


Hi Urs,

It's been discussed a while ago but apparently not much could be done about it, since it most likely related to upstream electron (mostly on windows) memory leak.

Perhaps for some it may be the straw that would break the camel's back pushing new users towards Linux. Keep it up, Microsoft! :wink:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.