How to search title that exactly match string with dash '-'?

I'm using joplin on windows, here is version info:

Joplin 2.8.8 (dev, win32)
Client ID: c94c7cd812b94b27a890e7530ef9de72
Sync Version: 3
Profile Version: 41
Keychain Supported: Yes
Revision: c2a6a13

I've written a journal plugin, and all my notes name are in the format of 'yyyy-mm-dd', before I try to create a new note, I would try to search whether a note with the same title already exists.

In my code I use let notes = await joplin.data.get(["search"], {query: title:${noteName}, type: "note"}); I also tried in search box:

pattern: title:2022-10-10

But unfortunately, the tile contains the character of dash '-', it seems has spectial meaning as the search pattern.

I also tried pattern: title:"2022-10-10", title:/"2022-10-10", but all in vain.

So what is the correct syntax for my searching?

Any clue?

Use basic search, all other search can't search special characters.

/2022-10-10

Hi @JackGruber, thanks for your reply, '/2022-10-10' will search note's contents too, what I expected is only search note's title.

yes that is so, the filter ignores most non-alphabetical characters. See documentation:

grafik
https://joplinapp.org/help/#searching