How to search on Android Joplin client?

In Android (any version of Joplin), how do you search for anything?

1 Like

There is a magnifying glass icon in the top right of the screen.

I see the magnifying glass in the list of Notes on the main interface. However, when I try searching for a string that I know exists in a note, it finds nothing.

When I go into a note, I see no way to search inside of just that note.

1 Like

I don't think you can, I think in the recent release the in built codemirror search has been exposed but only if you have a keyboard attached to press ctrl + f.

Remember that the string has to be exact or you can use wildcards or basic search as in the documentation.

Unfortunately even searching with wildcards fails.
The Android client is less functional than Notepad.exe :crazy_face:

Another thing, scrolling takes forever. Normally Android applications have a ballistically accelerating scroll profile. Joplin's is linear, so no matter how fast you swipe, it takes minutes to get to the bottom of a long document.

Is there another way to access Joplin files stored on self-hosted Nextcloud? Is there another client? Unfortunately the current version of Android Joplin is not sufficiently functional yet.

1 Like

I can't say I have any such issues in searching, I use it constantly.

As for scrolling, in the editor or viewer? If editor, are you using the beta one? Scrolling works as I would expect in the viewer.

Is there another way to access Joplin files stored on self-hosted Nextcloud? Is there another client?

No

I've tried many search permutations - it doesn't work properly in any circumstance.

The scrolling issue affects both the editor and viewer. The Viewer is smooth but has no scroll position indicator (scroll bar) and it has a linear scroll profile (takes forever). The editor is non-functional because of the severe lag. There's no practical way to scroll to the end of a long document because scrolling keeps popping up the soft keyboard, which halts editing. When it stops, it keeps taking touch input which causes many erroneous character inputs.

Under the Configuration menu, it says Joplin v2.8.1. I'm not sure if this is referring to the Android client version or not.

Thank you

Just for the record, there are also software keyboard apps that expose the Ctrl key (e.g. Hacker's Keyboard), so it should probably be possible to use the combination without a hardware keyboard too :wink:. It would still be very nice to have this search shortcut added to the app itself (e.g. through a button).

The viewer does not appear to be linear for me, the harder you flick the faster it scrolls. It does have a scroll bar but you can't grab it as a handle.

As before, which editor are you using (i.e. did you opt into it in the settings)? The beta one has proper scrolling and doesn't keep bringing up the keyboard.

This is the version of the app, yes. You can upgrade to the released 2.9 if you want but there are issues in getting it published to the play store - What's new in Joplin 2.9. This version has a lot of QoL improvements to the mobile app.

I'm sure the software isn't coded to handle the various API calls of the various versions of Android.

Regarding the editor, I made no modifications to the one available on the Google store.

Why is the new one having problems in the Google store?
A: Nevermind... i just read why on the link above.

I just opted into the beta versions under Configuration.

I just installed the v2.9.8 APK. I assume it will update this version from now on automatically? Or will it require subsequent manual installs when a new version is released?

Scrolling in the viewer is better now, but the scroll bars are still completely absent. Still takes forever to get the bottom of a long document. With a scroll bar I can grab the handle and quickly get to the bottom.

Editor scrolling seems to work, but likewise no scrollbar with handle, suffering from the same problem as the Viewer.

Also, there is no Search inside of the Editor and Viewer. Search would need to exist within the currently opened document as well as scoped to a specific notebook or all notebooks.

Search is still not working otherwise. I just tried various permutations.

No it won't be automatic, you would need to install manually until a new version gets published to the play store where you will need to install from there again.

It sounds like there might be a problem with the app and your device. Version or something else. Scrollbars should be showing (on the viewer at least) even if they don't have a handle to grab.

Search not working sounds odd too, if I search for "onion" it brings back all kinds of stuff for me and highlights the found result.

As for scoping, it has all the same functionality for search queries as the desktop version.

Probably better to raise an issue on GH with your android version etc.

I'm certain this is not properly coded for whatever version of Android I'm using... I have a Samsung Galaxy Note 9, which is a flagship device, so it probably keeps some degree of Android currency.

Hopefully they can add search inside of a document, which would change it from being totally broken for me. I can't use it without search inside of a document (not to be confused with global search).

I also hope that CSS styling is integrated into the core Joplin code since I'm using lots of custom CSS to extend markdown.

As I said, raise an issue on GH for it as it seems something isn't quite right somewhere as I can't replicate what you are seeing on my own device. You will need to provide as much info as possible such as the android version you are using.

It has been added already as already mentioned a few times in this topic. It currently requires some way of accessing "ctrl + f".

Err, yes? You can style Joplin with CSS if that is what you are asking.

I'm running Android 10 (June 1, 2022 security patch level), the latest available for this cellphone. Android 12 appears to be the latest in existence otherwise. I don't know of any way to update this device to Version 12 since Samsung appears to only be doing security updates. I wanted to run a secure OS, namely GrapheneOS but it requires a Google Pixel phone, and they don't even have a 3.5 mm jack anymore.

CTRL+F on a mobile device is not a good solution. I can't use it currently. Installing the hacker keyboard software and replacing the Samsung keyboard creates significant loss of functionality elsewhere. The search would need to be native to the Viewer and Editor.

Regarding CSS, I know Joplin supports CSS. I'm currently making heavy use of it in Windows. The problem is that the CSS does not automatically translate over to Linux, Android, and iOS. I'd have to manually put the CSS files into the respective filesystem.

Overall I want to see Joplin succeed as an open source replacement for OneNote, which I'm moving away from. But, Joplin still acts very much like Alpha level software. I have tons of feedback for the desktop GUI as well since I use it quite heavily.

Because it is currently designed to be used for tablet/desktop mode. If there is a desire for it to have proper mobile support then it should be raised in the #features channel.

The mobile app does not feature customisable stylesheets yet and they don't sync between clients, no.

I can only assume you don't know what actual Alpha level software is like. Small niggles with the app in your specific use case or bugs that have only been noticed by yourself so far does not alpha software make. As I keep saying, feel free to open an issue on GH for anything that is an actual bug like searching not working.

Yes the mobile app is far from perfect but it is more than usable for my purposes for example which is mostly as a quick note lookup device, not for editing or significant reading/consumption which is where I use the desktop app.

1 Like

Just to make this clear, have you enabled the beta editor in the Joplin settings? This is something completely different than opting into beta versions on the Play Store.

Yes

With the beta editor enabled, you should see a search button for searching within a note:

2 Likes

Yes thanks. I see it on the latest APK version when I go into the editor (not ideal) but not in the viewer.