How to completely uninstall Joplin from Linux Mint?

I installed the latest version via the terminal command. I tried Joplin and didn’t like it - I don’t like markdown style of text. How do I uninstall Joplin?

I’ve seen others ask this question and they were told to delete some folders. Is that really the official way to uninstall this program? I don’t want to delete settings and personalization. I want to completely remove the software.

I’m actually irritated that this information isn’t easily available. I had to create an account here just to ask this question.

Sounds like you found the answer and made an account to complain?

To answer your question about why we don't have a better un-installation method on linux. People that contribute to Joplin don't uninstall, and people who uninstall don't contribute. That said, it wouldn't be too hard to add an uninstall option to the script, I'll add it to my list (someone else feel free to do this first).

As the other posts on this forum say just delete
~/.joplin // Contains the executable
~/.config/joplin-desktop // Contains configuration and notes
~/.local/share/applications/appimagekit-joplin.desktop // is the desktop file

btw Joplin has an experimental WYSIWYG editor (not markdown which you might be interested in. Feel free to check back in a couple months.

2 Likes

No I didn’t make an account to complain. From what I understood, the answers to the previous uninstallation questions only deleted the personalization files, so that the person can start over with a fresh slate of Joplin. I clarified in my post that I’m looking for an uninstallation of the program.

I’m sorry you got confused.

In Linux you uninstall a program by deleting its executable. This is the same for all programs, not just Joplin.

This should take care of everything. If you’re still seeing something is left, try logging out.

Thank you. Yes I’m new to linux. It makes sense now. However, I’m still having trouble finding those files suggested by the other person.

Maybe it’s because the files with the dot in front of them are hidden.

Pressing ctrl+h in a folder should enable you to see these files in the file explorer.

Alternatively they can be deleted using the following terminal command

rm -r ~/.joplin
rm -r ~/.config/joplin-desktop
rm ~/.local/share/applications/appimagekit-joplin.desktop
1 Like

Got it. Thanks homie.

Thanks broseph

I ran the below 3 commands that are posted above:

rm -r ~/.joplin
rm -r ~/.config/joplin-desktop
rm ~/.local/share/applications/appimagekit-joplin.desktop

However, I still have a directory called the below. Do you happen to know what this dir is used for? I assume it should be deleted too.

~/.config/Joplin

The contents in this dir are:

drwx------. 3 workstation workstation  4096 May 28 16:13  blob_storage
drwx------. 3 workstation workstation  4096 Apr 28 14:06  Cache
drwx------. 4 workstation workstation  4096 Apr 28 14:03 'Code Cache'
-rw-------. 1 workstation workstation 20480 Apr 28 14:06  Cookies
-rw-------. 1 workstation workstation     0 Apr 28 14:06  Cookies-journal
drwx------. 2 workstation workstation  4096 Apr 28 14:03 'Crash Reports'
-rw-------. 1 workstation workstation    88 May 13 15:43 'Custom Dictionary.txt'
-rw-------. 1 workstation workstation    80 May 13 15:43 'Custom Dictionary.txt.backup'
drwx------. 2 workstation workstation  4096 Apr 28 14:03  Dictionaries
drwx------. 2 workstation workstation  4096 Apr 28 14:03  GPUCache
drwx------. 3 workstation workstation  4096 Apr 28 14:03 'Local Storage'
-rw-------. 1 workstation workstation   558 May 28 16:13 'Network Persistent State'
-rw-------. 1 workstation workstation    97 Apr 28 14:03  Preferences
drwx------. 2 workstation workstation  4096 May 28 16:13 'Session Storage'
-rw-------. 1 workstation workstation   371 May 24 18:09  TransportSecurity
-rw-r--r--. 1 workstation workstation   142 May 28 16:13  window-state-prod.json

You can delete that too. It holds the electron specific configuration, so it's config that isn't created by the Joplin application, but by the library Joplin is using.

It makes me wonder if maybe we can control where that is, config isn't a good place for it.

1 Like

Since it is not documented, posting the commands to uninstall Joplin on Linux for quick access:

rm -r ~/.joplin
rm -r ~/.config/joplin-desktop
rm -r ~/.config/Joplin
rm ~/.local/share/applications/appimagekit-joplin.desktop
1 Like