Having synchronization issues with error message

Operating system


Joplin version


Desktop version info

Joplin for Desktop

Copyright © 2016-2024 Laurent Cozic
Joplin 2.14.20 (prod, darwin)

Client ID: f13c43e717a54f09aaf7ba0ac66d639e
Sync Version: 3
Profile Version: 46
Keychain Supported: No

Revision: cfd98e3

Backup: 1.4.0

Sync target

Joplin Cloud

What issue do you have?

I hit the Synchronise button (which worked when setting up synchronization, but apparently not after that first time) and get an error message and not up-to-date notes.

Created remote items: 1.
Completed: 24/04/2024 18:38 (2s)
Last error: Error: Error: SQLITE_READONLY: attempt to write a readonly database: DELETE FROM sync_items WHERE sync_target = ? AND item_type = ? AND item_id = ?: 10,13,dca40902e6174e8aae1c2bb0f2bb0f7d


Screenshot 2024-04-24 at 7.51.10 PM.png

fixed my own issue. from Joplin's "Open developer tools" Console, there were several write issues to files. so I ran this as root user from command line and it worked. here is what I ran:
sudo /Applications/Joplin.app/Contents/MacOS/Joplin

1 Like