GSoC2020- Intoduction to community

pretty good question how to test mobile apps if you don’t have a ios and/or android phone.
Both offering SDK with emulators I don’t know if that is enough? May the community can help us out here?

For providing evidence that you code is working, we would like to see screenshots, gifs or screen recordings.

Le jeu. 13 févr. 2020 à 13:23, Antreev Brar via Joplin Forum a écrit :

@PackElend Thanks for the quick reply but i would like to know more on how to run this joplin master codebase on ioS emulator. Perhaps if you can describe me some steps ,than that would be really helpful.

I don’t have anything Apple related.
@laurent, how you do it normally?
All what I can provide is

Did you go through the introductory post? 🌞 Thinking of joining GSoC 2020? Please read this first! 🌞

In particular it says to read where you’ll find the instructions below, which explain how to build and run the application. Did you try this? And if you did, what didn’t work?

Building the Mobile application

First you need to setup React Native to build projects with native code. For this, follow the instructions on the Get Started tutorial, in the “React Native CLI Quickstart” tab.


npm run tsc
cd ReactNativeClient
npm install
react-native run-ios
# Or: react-native run-android

that says

Running your app on a simulator or virtual device

Expo CLI allows you to run your React Native app on a physical device without setting up a development environment. If you want to run your app on the iOS Simulator or an Android Virtual Device, please refer to the instructions for “React Native CLI Quickstart” to learn how to install Xcode or set up your Android development environment.

Once you’ve set these up, you can launch your app on an Android Virtual Device by running npm run android , or on the iOS Simulator by running npm run ios (macOS only).

what may end up with the same said in my link

@laurent i tried building the app as per the given instructions . I was able to successfully build the app as per the “Get Started” (tutorial) on the React Native official page.
Then after that when i ran

npm run tsc
cd ReactNativeClient
npm install

in terminal ,it gave me an error . I am attaching a screenshot of terminal window.

i would really appreciate if you can point out where it’s breaking down.

@antreev-brar I think you’ve missed building Tools:
npm install && cd Tools && npm install && cd .. (run in the root folder)


@daukadolt thanks for the quick reply . You were right, somehow i think i may have missed that ,now i am just facing an issue on the last command

react-native run-ios

Here is a screenshot of terminal ,i hope you can help me with this one more time.

@antreev-brar I haven’t built the mobile version yet, but seeing your logs I think you need to do npm install -g react-native-cli

@daukadolt just tried it .

Missing write access implies the need for using sudo prefix in the command, but that’s strange. I’ve never seen that problem on MacOS. For now you could do sudo npm install -g react-native-cli, but that’s a bad practice (in my honest opinion). I’d suggest you to take a look at

@daukadolt I did install react native using sudo, but can you tell me the possible scenarios why the BUILD can fail ?

I am really grateful that you are taking out your precious time to help me build the environment in my system .

@daukadolt I’mffollowing the discussion.
I’m wondering if there is not any kind of check scrip, to prove if all libraries are installed.

How about a standard project to compile fir purely debugging, if that works all is set.

Sorry I mainly on mobile these days, can’t write that much

From some research you could take a look at this discussion. Try to run down the issue timeline, take a look at most liked replies.

I haven’t done any react Joplin yet, so this is purely from doing some google research.

Hope it helps.

@PackElend not that I’m aware of.

I just follow

@daukadolt thanks for the reply. After following the instructions in the discussion link, I was able to succesfully build the app but when it shows another error on ios simulator.

Do you have any idea ,what this might be about?

Any results Googling it?
I found Solving React Native’s “No bundle url present” Error

Hi there,
time is moving forward and the deadline is closing in but we haven’t heard that much from you recently.
You are getting along with the code?
If you have any troubles don’t hesitate to ask around in the forum.

Don’t forget to watch/subscribe to the GSoC Live Blog to stay tuned.

good luck with GSoC

Hi, @PackElend can you please provide guidance about how to run the code locally on windows with android emulator.

I’m not that depp in the code yet, why not creating a topic in #development and describing what you have done so far and where you got stuck?
There will be help
Windows it a bit tricky from what I learned.