Extremely slow syncronization with Nextcloud

Operating system

Windows

Joplin version

2.12.19

Desktop version info

Joplin 2.12.19 (prod, win32)

Client-ID: f4ccb9fd603840eb875457d659c6a735
Sync-Version: 3
Profil-Version: 43
Unterstützter Schlüsselbund: Ja

Revision: 7081046

Sync target

Nextcloud

What issue do you have?

I'm an Evernote refugee and am currently trying to sync my notes with Joplin (about 4GB). Unfortunately, the synchronization process is extremely slow. Does anyone here have an idea how to speed up the process?
Thank you in advance for the help.

One way to speed up sync is to disable downloading resources to your mobile devices (in the settings) :eyes:

Thanks for the advice. But that won't help because I haven't set up Joplin on a mobile device (yet).

What else can help is increasing the number of concurrent connections

Other than that, sync speed is very dependent on the server speed of processing. 4GB is quite a lot of data to process and not many free services are offering good speeds. I think in your case, Joplin Cloud makes quite a lot of sense. So, worth to consider :eyes:

I've already tried it out. I don't feel like it's changed much, but I don't know what the exact meaning of it is either (I'm still fairly new to Joplin)

I already pay for the external server on which I have installed Nextcloud, among other things. I think 60 euros a year just for a text archive in which I only work irregularly is a bit much. I guess I'll have to keep trying.

gotcha, could you tell what the rate of sync are we talking about?

Also, to have more detailed information let's see the logs

I would simply let it sync over night, no matter how slow. It could be the free service throttles the connection, it could be many other reasons. But once it's all on your nextcloud drive, you will hardly notice the sync process in the future. Just be patient.

I'm sorry I'm just now responding - I've had a stressful week. But thank you very much for the answers

Thanks also for the link. There are two (recurring) messages:

The first message:
xxx\AppData\Local\Programs\Joplin\resources\app.asar\node_modules@joplin\utils\dist\Logger.js:213 10:39:32: Synchronizer: Sync: fetchingProcessed: Processing fetched item.

This message comes exactly once every second. It is always “Logger.js:213”

The second message:
DevTools failed to load source map: Could not load content for file:xxx/AppData/Local/Programs/Joplin/resources/app.asar/moveToFolder.js.map: Unexpected end of JSON input

Does these error messages mean anything to anyone?

„I would simply let it sync over night, no matter how slow. „

I thought something similar too. I let Joplin work throughout my workday. I want to upload on the desktop PC and then synchronize Joplin with two laptops. However, a maximum of a few hundred MB are uploaded per day. .

I have two ideas for solutions by myself:

First:
I still have a Dropbox account. Although I actually wanted to slowly move away from Dropbox, I use it for this if necessary.

Secondly:
I saw that all data is saved in the .config folder. This irritates me a bit, but okay - I'm a layman.

Is it possible to insert the Manuel folder here without breaking anything? This could speed up the synchronization of at least the laptops.

I'm not quite sure which folder is meant here, but it should be noted that Joplin is always establishing a direct connection with the respective cloud service (unless you've chosen file system sync). So there's no need (and AFAIK no option) to change Joplin's local data directory.