Enhancement Align Columns not working

Operating system


Joplin version


Desktop version info

Joplin 2.12.18 (prod, linux)

Client ID: ee29a844e8d448f39f9b56b154e84862
Sync Version: 3
Profile Version: 43
Keychain Supported: No

Revision: e47b908 (master)

Enhancement: 1.2.1

Sync target



Markdown Editor

What issue do you have?

I have just realized that the align text columns from left to Center, right are as blocks is not working by pressing the Buttons.

I have deselected all Markdown settings disable all plugins up to 'Enhancement' also there I deselect all settings
up to The first 'Enable table formatter in editor' and still could not align Text to the Center are to the right.

I'm on Manjaro and also test the 'joplin-appimage 2.12.19-1' version in a VM with the same issue

Joplin 2.12.19 (prod, win32)

Client ID: c475b891f5de4c7b898e5128d817f658
Sync Version: 3
Profile Version: 43
Keychain Supported: Yes

Revision: 7081046

Spoilers: 1.0.6

Can also say this is not working on Windows version either, Cell Properties, for instance align to Top is aligning to top, but if you move to another Note... its back to default.

Hey, there!

If you are using the Rich Text editor, it seems that the alignment configuration for the table does not affect the cells content, but the table location instead. But, as the warning at the bottom shows, the Rich Text editor has a number of limitations, and the create feature is just a way to simplify the table creation for Markdown (Joplin uses Markdown in all notes as far as I know). This worked for me when editing a table using Markdown:

If you need something more complex or different, I think the only option is to use a plugin or maybe an external editor that is capable of adding HTML to the document.


So it's looks like this is only works for table, not for markdown notes..

You can align contents in markdown tables using colons, please see the link in my previous post.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.