Encrypted documents not decrypting on another device after sync

Version: 2.11.2

  • Boox Nova Air
  • Samsung A53 5G (2022)
  • macOS Ventura
  • iPad

I have had Joplin running without issues across four devices (see above list).

I synchronise via Dropbox. I have encryption enabled. That has been working fine until now.

I hadn't used Joplin on the Nova Air device for couple of months nor on the iPad. When I opened Joplin on the Nova today it synchronised and downloaded all my new notes from Dropbox. All of those new notes and notebooks had been written or created on the Samsung phone.

After the sync, I can see in the sync status that the Nova Air has the same file and notebook count as the Samsung. However, all the new items that downloaded didn't decrypt. I see in the Sync Status on the Nova Air a list of "Items that cannot be decrypted". It says, "Joplin failed to decrypt these files multiple times, possibly because they are corrupted or too large. These items will remain on the device but Joplin will no longer attempt to decrypt them".

Then there is a long list of Revisions (likely a hundred or more), numerous Notes, and some Folders.

I tried the "Retry All" button, and the list vanished. When I refresh the status page eventually the long list of items reappears (as failed decryption).

There has been no issue with the items from the Samsung syncing to the macOS device, and successfully decrypting.

I also did a sync to the iPad today, which hadn't been sync'd since shortly after I first started using Joplin. It downloaded all 414 notes, and associated folders, etc., and had no issue decrypting them.

To resolve this issue on the Nova, should I just uninstall the app, reinstall, and start it from scratch?

What I've since done is this:

  1. Cleared all app data for Joplin on the Nova device. That reset the app back to default and new setup.
  2. Set up sync with Dropbox.
  3. Was prompted that Encryption hasn't been configured. So I added in the master key.
  4. Sync proceeded.
  5. Same result.

By step 4, I figure I was good to go. But oddly, what appears to be the same notebooks and notes, the same items that didn't decrypt previously have done so again.

I know there's no issue with the items themselves, nor with the master key. Since I completely reinitiated the app on my iPad today, and it had no problem decrypting everything.

What's coming to mind is perhaps the processing power of the Boox Nova Air is insufficient to decrypt the files quickly enough, and something in Joplin is timing out? I say this, because when I watched the sync refresh taking place on the Nova Air it went noticeably slower than on the iPad. In terms of the file counts that show up in the sync status.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.