Enabling encrytion

Never had problems with encryption (or setting it up) before. But when starting a new (independent) instance of Joplin on a separate desktop, I wanted to set up encryption following the instructions here : About End-To-End Encryption (E2EE) | Joplin
To my surprise the button in the encr. settings window called "enable encrytion" looks good, is not greyed out or anything ... and does nothing.
Does anyone have a clue how this could happen ?
I have not yet deleted and reinstalled Joplin completely from that device, but before doing so .... I'd rather ask on the forum .... HELP please :wink:

Are you using a v2.10.x pre-release?

I tried to activate encryption for a new install using v2.10.4 desktop (Win10 22H2) and it did not work, just like as you described. However I also installed the current release version (2.9.17) and encryption could be enabled.

I have not searched for this problem but if it has not already been reported it may be worth raising an issue on GitHub or maybe posting in the Beta Testing section of this forum that the 2.10.x version breaks this functionality.

@ajay, in the template that you've deleted without reading, it's asking you for the version info and logs. Could you provide that? How to enable debugging | Joplin

You are right, sorry for wasting your time. So ....

  1. I am using 2.9.17 now, but is it possible I had 2.10 running when the problem first occured. A complete reinstall did indeed solve the problem.
  2. yes, will not forget the debug logs next time. Thanks