Editing note, which is selected from a tag, breaks

Hey everyone, on the main dev branch.

  1. choose any folder.
  2. click on any tag that will display the notes attached to this tag.
  3. choose a note from the note list.
  4. start editing the note.

current behavior:

  • the note closes


  • the note doesn't close

here is how to produce it:

Doesn't happen for me.
Does your branch have any of your changes? If so, try without them.

Nope, I pulled the latest changes and switched to dev. I'll try to reproduce it again.

Ohh.. I think I know what the problem is. I'm such an idiot, sorry for wasting your time roman:)

I was able to produce it again, can you check? I'm so confused right now... @roman_r_m

2024-03-16 22-57-02.mkv (2.8 MB)

i produced the bug in #4217, but it still work without reproducing #4217

Was it your PR? are you sure you've reverted it and ran yarn install again? or at least recompiled TypeScript

I'm on dev, i have run yarn install from the project root..
then yarn watch from joplin/packages..
then i run yarn start from app-desktop

but i was able to produce it, i suspect maybe its like a broken note entitiy or smth, so i created a new note and tried to reproduce it.. i still was able to...

well, if you're able to reliably reproduce it you can try debugging
i pulled the latest dev and still don't see the issue

thanks for your time, again:)

I can't seem to reproduce this with tags, but I can consistently reproduce it with notes in the conflicts folder.

Strange.. i'll try to clone in another location and see if i can reproduce

I don't know if that's related but yarn watch should be launched from the root, not from /packages