Home    |    GitHub Page    |    API    |    FAQ

Custom CSS on Mac not working?

I put the custom userstyle.css and userchrome.css into .config/joplindesktop, but when I restart Joplin, everything looks the same.

When I click "Edit" under "Custom stylesheet for rendered Markdown," I can actually see the custom CSS code, but it doesn't seem to be going into effect.

Does anyone know what might be causing this?

It could be that Joplin was still running in the background? You can toggle dev tools then press F5 for a restart.

Nope, that didn't fix it.
This must be a problem with how I'm configuring it, because I'm getting the same issue on my Windows 10 machine.

You should probably at least share the css you are trying to use

It's this theme. From February 2020.

So that css looks like it works just fine for me on Windows and on macOS (its a nice theme too, I might adopt parts of it). I assume you are also putting the newsprint folder into ~/.config/joplin-desktop ?
Just to make sure, the userstyle.css won't do anything to the rich text/WYSIWYG editor, it only alters the rendered markdown output from the standard editor so is that what you are using?

Pardon my ignorance, I had long ago set it so that my only options were the raw markdown editor and the full WYSIWYG. Do you know if there's any way to change the font in the WYSIWYG editor? That's really the only thing I'd want to change.

Thanks, and can delete/lock this thread as requested.

I could be wrong but I don't think you can style the WYSIWYG editor at the moment. It would be a nice feature though.