Copy/paste a Note with a screen copy in Thunderbird (or other docs) makes an invalid e-mail/doc

Joplin: desktop version 1.3.18, Windows 7, synced on network NAS.

I'm sorry but this is a critical problem for me :frowning:

I use Notes (also) as sort of canned message that I can paste in an e-mail.
I do this in both Cherrytree and Evernote (that I'm quiting): it works perfectly.

I select the whole content of a Note using CTRL+A, then copy CTRL+C, reply to an e-mail in Thunderbird, then paste CTRL+V.

It's a straight process, no confirmation, nothing to do, just copy from/paste to.

My problem in Joplin is when I do this with 1 or more embedded screen copies, images.

Exemple, this test note:

When I paste this in Thunderbird:

  1. Thunderbird asks me to authorize the inclusion of a file

I have to click on Options and click on the file name to authorize it (2 clicks):

  1. Much more, while it seems to work (the file appears in the email), when I send this message in fact it doesn't include the proper file.

This is what's Thunderbird ready to send:

This is what is received, there is no file embedded, just a file name:

I don't know how it works, but if that can help you, it seems there's a mismatch in the file name?

Here is the markdown view :

The last letters of the filename in blue are "fc5e.png" and in red it's written "e40c9b".

I'm not sure what it means, but apparently the source file is "fc5e.png"

But in Thunderbird in the screen copy above, the email shows a file "fc5e.png" but in the email body, it seems the file is "e40c9b.png"

And the attachment is "e40c9b.png" :


I also tried to paste to another document, a Word document, and an Evernote document.

Same problem - the paste is incorrect, see what it looks like in Evernote :


In résumé:

  • I should be able able to copy from and paste in any document, like a Thunderbird e-mail

  • This shouldn't require any authorization to include the image(s) as a file

  • It should make a proper document content, which is doesn't, right now.

Again, I'm sorry, but this is very problematic for my usage.

If you need more/different info please ask.

MANY MANY thanks.


guess You solved the problem ?

If not, it is as easy as it could be.
As shown in the first picture of Yours, Thunderbird blocks the picture (because a screenshot is just nothing else) itself, but not the name of it. Therefore You have explicit to unblock/allow these kind of contents.