Completed To Dos on Top -Not working

Operating system


Joplin version


Desktop version info

Joplin 2.14.20 (prod, darwin)

What issue do you have?

I have a to do list and currently is not sorting the marked to dos at the bottom even though it is selected in the view menu. And actually none of the three checked (see picture) seem to create any change in the note. This is on a desktop Mac. I tried restarting the app.

Is there something I'm doing wrong or if a bug a way to fix it.

Help much appreciated.


Screenshot 2024-04-23 at 17.59.31.png

I'm not sure if I'm reading your message wrong, but those settings aren't for a single note but for the note list. It won't rearrange any checkmarks within a note. I think for that you can highlight the section and sort it (not sure if there's a menu point for that off the top of my head, but there's a shortcut you can look up in the settings). This will sort all of the lines alphabetically while putting completed ones on the bottom. Hope this helps.