Clipper on windows firefox cannot clip support.mozilla.org pages

Trying to clip this page and ran into a problem that sounds like this .

I can clip other pages in general, but I cannot clip any pages from https://support.mozilla.org . When I try, I get the message:

The Joplin extension is not available on this tab due to: Missing host permission for the tab

Is this something in the clipper configuration?

I've tried clipping in private window, re-installed the add-on with a browser restart, but it did not help.

I'm using clipper version 1.6.1 on Firefox 88.0.1 on windows 10. I don't think it's reached the desktop client at this point, but the info is below.

Joplin 1.7.11 (prod, win32)

Client ID: 91365061178a49ae9979526f6e992f33
Sync Version: 2
Profile Version: 34
Keychain Supported: Yes

Revision: f560563d8 (master)
1 Like

In about:config, the value of extensions.webextensions.restrictedDomains contains a list of values which no addon can interact with. You'd have to remove it explicitly.

It's done for security reasons as far as I can remember, though I can't remember what specifically they are. (I think there's a chance Firefox might let Firefox related websites access functionality that normal sites and thus extensions can't, and also to prevent extensions trying to hide their own remove buttons for example).

2 Likes

That was it. I tested by by removing the support.mozilla item in the about:config entry, reloaded the page, and the clipper worked.

Thanks for the pointer,

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.