Clearing search to remove highlight closes note

Using search automatically highlights every matching instance in a document and usually I want to remove this when I’ve found the note I was searching for. However, if I clear the search to remove the highlight, the note is closed and I’m back to where I started.

I can’t find any other solution to this but to check where the note is located and manually navigating there, which is not really optimal in my opinion.

Edit: This is on the Windows client

1 Like

No feedback? - is this not an issue for anyone else?

Could you add a bug for it on GitHub?

1 Like

i want to add to this old post, which seems to have all been forgotten.
do linux users experience the same thing?

because aside from the OP issue i'm also experiencing on top of that the annoyance that the search will continue to update while writing. this is just bad, only remedy to this is to not use the search.

edit: one thing that will reset the search is to close the app that still runs from the background and restart joplin from here.

I think what you're experiencing was a big on your version (unrelated to the original post) that has been fixed in the latest pre-release. The next update should function a lot better.

same here. I have to restart Joplin after a search.

Was actually going to write a feature/bug post for this but the system brought me here. I'm on 1.3.9.

@laurent if it's any clearer, steps to reproduce this:

  1. Search for item - 'anaconda'
  2. Query returns a bunch of notes - their titles highlight the search term, and the text inside the notes as well.
  3. If you start editing the note, the highlighting is still there in the note. If you write a new word containing the search term, this highlights as well.

It's a little bit annoying only, I can live with it for now!

I think the desired behaviour would be to just turn the inside note text highlighting off as soon as the editing starts - or the cursor is inside the note. I think the note title highlighting would be fine as is, or potentially just turn off as well with the editing, keeping the search results. Perhaps moving the cursor to the search box turns on the highlighting behaviour again?