Changes in Markdown editor after Joplin update or plugin update or?

Recently, I was aware about changes happens in the markdown editor.
Example

  1. Change "##" for "h2" and,
  2. Note link only showing if you click in the space showing in the another editor.


Could somebody help me to advise if this change happened after a plugin version update, or after installing
a new plugin, or CSS file changed, or based on other changes.
I would like to go to the previous set-up and I could not find the source of this change to revert it. Thanks.

That definitely looks like either plugin behaviour or a theme you have in your CSS files.
You can start Joplin in safe mode to check (Help > Toggle safe mode) but I think you are going to have to deactivate things or temporarily rename your css files to find what the issue is.

This is from the plugin called "Enhancements" (or "Joplin enhancements" on the left side of the plugins panel), after the latest updates.
I see the same thing. I disabled it and everything is back to normal.

Thanks for your help. (@blank and @Daeraxa), I have disabled it and confirm your finding.
@SeptemberHX, or who developed this excellent plugin,it would be possible to add these 2 sets up into the plugin to enable or disable these 2 features? I found the plugin very useful, except for these two functionalities that are not fit my way of working.

  1. Based on my light theme, "h2" is not visible very well and is difficult to guess which kind of title I created, instead of using different quantities of "#" to show them.
  2. As I work in the markdown editor every time, it is not easy, or at least requires extra effort, to know if there is or not a note link there.
    Anyway, thanks a lot for your plugin

Thanks for the feedback. I will add more setting options so that users can enable/disable each feature.

For now, you can disable Enable link, image, and footnote rendering in markdown editor to avoid the blank note link; disable Render markdown task to clickable checkbox in markdown editor to avoid the rendered hx items.

For the link on a separate line, you can also make it rendered normally with some other items. Like: - [xxx](xxxxxxx) for now.

If you have more advices on the Enhancement plugin, please let me know. :slight_smile:

1 Like

Perfect, thanks @SeptemberHX for your support.

Hello, v1.1.1 is now published. You can disable the hN rendering in the settings now.

And the blank widget rendered with links on a separate line is fixed now, and it is disabled by default.

Perfect. Thanks a lot.