Can't update single Android phone Joplin 1.3.13

Joplin 1.3.13 (originally posted 1.3.15 by mistake)
Android V9
Synced over OneDrive

I have 2 cell phones, one running Android 8.0 which updated fine.

My second phone runs Android 9. When I go to the Play Store and check for updates it shows the new Joplin ready to install. I click update, it downloads then throws an error stating it could not be updated.

I have rebooted the phone and tried over the period of 12 hours sever times. The OTHER phone updated just fine during those hours.

Previously I have uninstalled and reinstalled an app to fix such issues. However with the sync and encryption I am hesitant to do so with Joplin. The last time I uninstalled it it goofed up everything terribly and I ended up having to reimport my notes and setup encryption again on ALL my devices.

Please advise the proper way to remove Joplin from the Android phone and reinstall with triggering the Joplin ;'Fail Safe' or messing up sync or encryption.

There's no 1.3.15, do you mean 1.3.13?

Also if you can run adb logcat while you install the app, it will tell you what the actual error is.

Or perhaps try to install the app, note the exact time you did so, then try to export a complete log Then you can search the time and would probably find the actual error too.

I'm on a motorola g7 android 10 and am getting a generic error about "cant install Joplin....reasons". No specifics. I am getting ADB installed to pull the logs and will try to submit a crash report. I have followed all the troubleshooting advice from google about cleaning up play cache, download manager, clearing space in general, reboot phone endlessly, etc. No love. The other app that also stopped updating was "Spaceteam" but other than coincidentally ceasing updates at the same time... I don't know if it's related. Other apps updated at the same time successfully.

Log to big to upload from bug report, but logcat output for that span is attached.logcat.txt (76.6 KB)

Sorry it took so long to get back, been wild here.

I re-ran the update from the Google Play Store and it again failed. I started Joplin and went directly to the logs.

These messages are from September and October

Yes, they are, damn, I didn't realize what the digits were in the lines. There are no errors then for the time that the upgrade failed. I again ran the update, it failed and I went to the logs. Updated screenshot above, for all it's worth.

I know I messed up my encryption and the notes once before by messing around in the Android version - although I was messing with sync targets too. Wil it do the same if I delete the app and reinstall it? Or will it be a fresh version be installed requiring it to be setup again? That is IF it installs at all.

I had another app do the same thing last night, I cleaned up all the caches, still no go, so I deleted it, went back to the store and re-added it and it installed again fine. Hopefully Joplin will do the same.

Same with me, on Android 8 Tablet update is working, on Android 9 not.
Workaround: Go to , download the proper (32- or 64-bit) apk file and install. Not as comfortible as with PlayStore, but working. And since I don't really like the Google PlayStore, I even prefer this way (would even more prefer finding Joplin at

Thanks Harald! I never noticed the direct download . Did so and it installed fine.

Thanks! Solution worked perfectly.