Can't delete files on Joplin portable

I'm on Windows 10 running Joplin Portable V 1.4.18.

I can't do basic operation that is to delete whenever I right click a note and press "delete." Every time I press delete, I get a Windows background sound. I tried using the debugger and checking on the console, however, the console did not log anything when I tried deleting.

Any idea on what could be the cause of this?

Edit: The problem was on my PC.

The sound cames from the confirmation dialog.
Then you do not see this dialog either?

You can enable debug mode to possibly collect more information.

I don't

I already did. It the console didn't log a thing that relates to deletion. Not even an error. Just a Windows sound.

I might try to use Joplin portable along with the profile on a different PC. Maybe that'll yield some results.

Slightly off-topic but the laptop I'm using probably has a corrupted OS. However, it is shared and the owner didn't want me to reformat because they didn't want to lose files. Maybe this is a possible issue? I don't know, I'll test this theory.

Nevermind, I confirmed that the issue was on my side. I resolved it by using other PC.