Bug: Inline Code Formatting in a table does not persist after switching between RTE and MD editor

Operating system

Windows

Joplin version

2.14.10

Desktop version info

Joplin 2.14.10 (prod, win32)

Client ID: 4dab185d885945ac897a0608af59c6f7
Sync Version: 3
Profile Version: 45
Keychain Supported: Yes

Revision: 3ed6ad5

CodeMirror Options: 1.1.0
Csv Import: 1.0.1
Favorites: 1.3.2
Menu items, Shortcuts, Toolbar icons: 1.1.0
Quick HTML tags: 0.2.0
Simple Backup: 1.3.6
Simple Highlighter: 1.0.0
Suitcase: 0.3.2

Editor

Rich Text Editor

What issue do you have?

Text formatted as Inline Code within a table does not persist after switching between the RTE and markdown editor.

A: Create a table and populate it with content.
B: Select any text in the table, and press Ctrl + ` to format the text as inline-code.
C: Switch to the MD editor. Notice that all inline code formatting has been stripped.
D: Switch to the RTE editor, and confirm all inline code formatting is gone.

Summary:

Unfortunately, in the current state of the application, this doesn't seem to be supported.
The only work around is to manually place code tags around the text you want to be rendered as inline-code directly in the markdown editor:

<code>mycode.value</code>

It would be much appreciated if inline code support in tables would apply and persist when setting it in the RTE.

Thanks for any consideration. I would really like to see this supported.

Related Github issue with screenshots:

Screenshots




Steps to Reproduce:

  • Create a table and add text.
  • Format text as inline code using Ctrl+` in the RTE.
  • Switch to the Markdown editor.
  • Observe that inline code formatting is removed.
  • Switch back to the RTE, and formatting is still missing.

Workaround:

  • Manually add code tags () in the Markdown editor.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.