Bug? desktop install on Debian Linux: Joplin not starting

Thanks in advance for reading this post.
Having just installed Joplin as an android App I decided to try it on a computer, but I am not having much luck with that.

I am not very knowledgeable with Linux, so apologies if this post lacks necessary detail. I have tried to install the latest version using the script listed on your website. Which will presumably identify and use the latest version.
I do get a Joplin icon installed, but it does not start up from the icon.
I used:

wget -O - https://raw.githubusercontent.com/laurent22/joplin/master/Joplin_install_and_update.sh | bash

I am using 64 bit Debian Linux 9 (stretch) Gnome

I did notice the post

Linux AppImage 1.0.216 not starting

and wonder if that is in any way similar to my issue.

Can anyone suggest what I should try to do to investigate and resolve this problem.
I did not see any open bugs and maybe it is just s fault on my system rather than any bug or problem with Joplin.

If I try typing in to a terminal it does not start when I try joplin or joplin-desktop
And I see no help files

jphvd2@deb-vaio:~$ apropos joplin
joplin: nothing appropriate.

Cheers, John

(Minor edits for typos, plus title modified as noted within posts)

Have a look here and see if that is applicable to your case.

Thanks for the quick reply eagle.
That has partially solved the problem. Pity I missed finding the post you referred me to.

To get a better solution I now need to figure out how to actually edit the launcher icon in Debian Gnome.
Joplin does start up if I use the CLI and add the no-sandbox option

jphvd2@deb-vaio:~$ .joplin/Joplin.AppImage --no-sandbox

I suppose myself and presumably other users of Debian … would be interested to know if this procedure or workaround is documented anywhere?
Removed reference to Mint, because per post under Mint may be unaffected by this issue. )
The current subject line for this post is
Bug? latest desktop version install on linux
I have edited that to
Bug? latest desktop version install on Debian linux (Joplin not starting)
It may not read as well and is longer, but more informative

Fortunately that’s really easy to do on gnome desktop (and others that more or less follow the free desktop standard).
I suggest you do a google search for “desktop file” and read up on these, they’re good to know about and they control all the launchers in gnome.
The Joplin desktop file is stored ~/.local/share/applications/appimagekit-joplin.desktop you can simply open this file and add the --no-sandbox flag

Good luck!

Thanks CalebJohn
That worked and solves my problem.

I will further amend title from
Bug? latest desktop version install on Debian linux (Joplin not starting)
Bug? desktop install on Debian Linux: Joplin not starting

I will in due cause mark this as solved.
My remaining question is:
Is this a known issue and already documented or under enquiry ?
I will leave it a while & see if anyone else can add helpful information about the situation.

Many of the comments and discussions are beyond my understanding, but I get the impression there have been changes in Debian Security and changes in Joplin.
Whatever the actual situation this is hardly optimal, but on the other hand it is a simple enough workaround.
I note there are about a dozen hits on searches for “–no-sandbox” { Search } and that includes news about two Releases and #2436
One of the main threads may be Unable to start 1.0.179 (on Linux)

Vanilla Debian has a rather interesting security model, which is not the case with many other Debian derivative Linux distros (Ubuntu, Mint, …).
This is the only workaround that seems to work in a problem with no direct solutions.
@laurent, @tessus, could you please put this workaround on the docs page since this seems to be a very common problem with a relatively efficient solution.

1 Like

Thanks RedDocMD,
I will now mark this as solved, and appreciate your looking at this problem and the documentation situation.

I will mark CalebJohn’s post as the solution because it mentions both the --no-sandbox flag and modifying the .desktop file to permanently fix the launcher.