Joplin doesn't start

Hi,

I've installed Joplin 2.8.8 on my laptop runned by Debian 9, using the recommended method (with a command line).

The app seems to be installed, the icon is in the application panel… but when I click on it nothing happens at all. I don't have any error messages, just nothing.

I've tried reinstalling the app, but the installer told me "Joplin 2.8.8 already installed".

Can you help me? Thanks in advance!

What happens if you run the appimage directly via the terminal? Assuming you don't have some kind of appimage integration tool like appimage launcher then it should be in `~/.joplin'.

I'm not a Linux expert, but I went to the directory and tried this command line:

./Joplin.AppImage

I got this answer:

[7902:0730/084638.549079:FATAL:setuid_sandbox_host.cc(158)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /tmp/.mount_JoplinDXVWsG/chrome-sandbox is owned by root and has mode 4755.

I've also tried the same command as superuser, and here is what I got:

[[0730/084710.981683:FATAL:electron_main_delegate.cc(297)] Running as root without --no-sandbox is not supported. See https://crbug.com/638180.

Try running with --no-sandbox. I think it is needed for older Debian versions.

It worked! First, I got this:

Fontconfig warning: "/etc/fonts/fonts.conf", line 100: unknown element "blank" xdg-settings: invalid application name Try 'xdg-settings --help' for more information. [5667:0730/133613.148408:ERROR:sandbox_linux.cc(374)] InitializeSandbox() called with multiple threads in process gpu-process. (node:5624) electron: The default of nativeWindowOpen is deprecated and will be changing from false to true in Electron 15. See https://github.com/electron/electron/issues/28511 for more information. (Use @ joplinapp-desktop --trace-warnings ... to show where the warning was created)

And then, a few seconds later, Joplin started. Thank you!