Bold text not very....bold?

Joplin Desktop 1.0.245, Windows 10

I've just noticed that text marked as bold not particularly boldened, both in Joplin and when exported to PDF. In the attached image I'm using the Nord theme, but it is the case in all of them.
Compare with markdown rendered in for example Atom:

Or even just here on forum: normal text, bold text

I find the Joplin bold quite lackluster. Is this intentional or is it a bug? Is it possible to easily change it for myself?

It sounds to me that you are experiencing the problem not only in Joplin but in all applications.

This is how my browser (Windows 10, Chromium-Edge) renders the text you've written:


I'd say the bold font is quite okay.

You may want to check your desktop renders other webpages using Arial Bold like Google fine:


Do you use css styles?

This is how it looks on my Windows 10 (2004) with Joplin 1.1.3

First, it would be great to know, if the OP had the same problem with another theme. In this case we can narrow it down a little. Then the OP should provide more info as JackGruber mentioned. Is user-supplied CSS involved?
Without information there's nothing anyone can do.

Well, the OP wrote that bold is OK in other apps, including the Web browser.
And that they tried various themes with the same result.

I see the style of text uses Avenir (a font I don't have, AFAIK, not sure if Joplin provides it), or Arial, with a sans-serif fallback.
Perhaps one font installed on the system of the OP matches these names, but lacks a bold version and the simulated result is dim as shown?
Anyway, this looks like it is not really a Joplin issue, more like an issue with the system of the OP.

Might be interesting to try another font, like: <div style="font-family: 'Times New Roman';">Simple and <strong>bold</strong></div> and change the font name to one of the above to see if there is a difference.

Thanks for the replies.

I am using the default CSS of any given theme. As I've mentioned in the opening post, I've indeed tried different themes and the font that Joplin uses still stays the same. In other apps, such as a web browser or Atom, things are rendered correctly.

I've checked the fonts used by the Nord2 theme, and it should be Roboto and Fira Code. Since it was optional, I didn't install them before, but now I did, restared the computer, and observed no change.

As to the test suggested by PhiLho:

As I was writing this, another thing occured to me: I was running Joplin as a user without admin privileges. When I run it as an Admin, I can observe correct behavior:

Do you have any ideas what's the problem and how can I get normal behavior without elevated privileges?

The last part (admin) is particularly puzzling…

Unfortunately I am not able to reproduce this. I don't have a Windows machine.