Home / GitHub Page

How can I make the editor font bolder?

Hi

Is it possible to make the font a bit bolder? I use the dark theme and the characters are so tint they look very faint on my screen. I am wondering if I can make them look abit contrasty, I might be even ok with disabling antialiasing in Joplin (but not system wide).

thanks

@kartoo

I was thinking that as a “quick fix” you could possibly search for a heavier/bolder monospace font, install it and specify that under Editor font family in the Appearance settings?

1 Like

The easiest method is probably to increase font size, or as @dpoulton suggested you can change the font.

The more complete answer is that Joplin supports a userchrome.css thanks to the recent work of @devenzuegel . I think this can be used to make the editor text bold, but unfortunately I haven’t dug into it yet and don’t know exactly how that could be done.

2 Likes

Thanks, I now enbaled Bitstream Vera Sans but I feel like the editor scroll speed got a hit with the new font. Would such a hit happen due to font change?

I am not a dev so I cannot say if there may be circumstances where specifying a font may cause Joplin to work any harder at anything. However I have tried this on my machine using Source Code Pro and not noticed any sluggish editor behaviour.

Thanks I will try that one too.

Welcome, however Source Code Pro is not a bold font (but it seems that it may be an Adode font - are they any better?).

I do not use black / dark themes because I am old and prefer my notes / docs to look like ink on paper! Many things make me feel old but this need to have dark modes or themes has dated me the most, I just don’t see the point :slight_smile: !!

Actually I found a bug with custom fonts and Vim mode.

I set the font to Bitstream Vera Sans and now the cursor stays far away from where it should be in Vim mode. See the image

When I edit, the cursor is still far away from the word ending but the new text is added to where it should be.

In the options where you choose an editor font it there’s a warning that you must use a monospace font. It looks like you’re not using a monospace font.

Unfortunately this is a known bug with the Joplin editor that likely won’t be fixed anytime soon. I would suggest switching to a monospaced font. It looks like Bitstream Vera Sans also comes in a Mono variant so that should be your best bet.

1 Like

Thanks, I will see whatelse is installed on my Linux system.