Automatic capitalization of search string hides keywords

IPad Pro iOS 15.3.1 Joplin 12.7.1

Can't easily start a query with a keyword, like 'tag:' because the first letter of the search string is automatically capitalized, and 'Tag:' isn't recognized as a keyword. So I type 'ttag: then backup to delete the now capitalized first letter.

Is this behavior actually intended - something to get used to? Is there a better workaround?

I'm not sure I understand this? If I go to the search bar then yes it is capitalised to start with but that is driven by the keyboard. If I put the keyboard into lowercase then it types in lowercase without any kind of auto correction?

On Android there is an option "Automatically capitalize" at the beginning of the sentence. When this option is on, I have the same behavior.

Are you also using an iPad Pro? My Mac does not auto-capitalize, only my iPad.

Far from it, I don't really use Apple stuff, I just checked on my work phone which is an iPhone SE on iOS 15 using pretty much everything as standard (i.e. standard keyboard and options as I barely use it for anything more than calls).

The app itself is the same whether iPad or iPhone.

I am embarrassed to report that Auto-Capitalization is a preference setting in IOS. Duh. With auto-capitalization off, my problem goes away. Naturally, I wish this could be set per application, so that I could have it on for Mail and off for Joplin. But users are like that.

Thanks for your replies.

1 Like

In the next version the filter keywords are no longer casesensetive.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.