AppImage 2.11.9 (prod, linux) migration issue


I started using your app when I was able to set up its portable appimage app :
|- Joplin.AppImage.home
|- Joplin.AppImage

I first downloaded the version from the website (Joplin - an open source note taking and to-do application with synchronisation capabilities) then I tried a 2nd time by clicking on the software update button to get to (Release v2.12.7 · laurent22/joplin · GitHub)
I then renamed the appimage file to Joplin.AppImageEX and the new file uploaded as Joplin.AppImage

Joplin 2.11.9 (prod, linux):
ID client : 728a3b2347e7450e8ee90b192582ad5d
Version de Synchro : 3
Version du profil : 42
Trousseau supporté : Non

Révision : 30671e7

If the problem is that Joplin does not appear to have been updated, you need to fully quit Joplin (File > Quit) and then restart it to enable the new AppImage to take over.

Note that if you run the installation script again it will update the AppImage for you and save you downloading, copying and pasting (still needs an app restart though).

1 Like

Ok thanks it's solved :slight_smile:
Only it's even more annoying when I want to change profile ( Linux - Profile switch warning ) . I have to open it 2 times before it opens on the right profile!

Joplin should open using the last profile you used. The current profile in use is stored in profiles.json.

Did that happen only the first time after the upgrade or do you now have to open it twice every time to get to the profile you were last using?

Joplin open, I still have to leave Joplin (as you said)...
This is the 2nd time it's opened correctly on the right notebook.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.