Portable Joplin Appimage

I run Joplin 1.0.193 on Linux. And I use the AppImage.

I want to have a portable version, so according to the documentation for AppImage all I have to do is have a folder named $(executable_name).home in the same folder and, in theory, ALL files should be hosted in that folder.

Yet I notice there is a /home/$(user)/.config/Joplin folder that is in use and has quite a lot of data.

Is there something I am missing? How do I get Joplin to behave and hold ALL its data in the ./$(executable_name).home folder?

Thank you.

That’s interesting, can you point me to the documentation where you saw that? I’ve never heard about that, but if it’s a fairly normal feature I could look into seeing if Joplin could support it.

That said, the Joplin has unofficial support for manually specifying the profile (where all the data is stored) meaning you can use the --profile flag on the command line to specify the location. If you search these forums for --profile you should find what you’re looking for.

1 Like

I’m almost certain the only portable version available was the Windows version; maybe the documentation doesn’t make that clear and needs to be reworded a bit?

In the Official Documentation
https://docs.appimage.org/user-guide/portable-mode.html

“Almost certain” usually means “no idea”. Please, do not hijack a practical issue.

I don’t appreciate the hostility. This is the second time you have been hostile towards me when my core role on these forums is support and these are an open forum where everyone assists everyone whenever they can. Thank you.

I was also referring to the Joplin documentation here. I hadn’t checked the AppImage documentation for it

I gave it a try on my workstation and it seems to work fine, I’m hesitant to continue testing too much in case it doesn’t work and I mess up my regular installation. If you get it to work please let me know, otherwise I’ll try to get around to fully testing this at some point.

The folder I created (in the same directory as Joplin.AppImage) was named Joplin.AppImage.home is it possible that you had a typo or something?

I have checked once more.
lsof -c joplin
of course the listing is huge. But there are three instances from the same process ID opening files in
/home/$(user)/.config/Joplin/GPUCache/
and, there is a folder
/home/$(user)/.local/bin/Joplin.AppImage.home/.config/Joplin/GPUCache
yet Joplin does not use the second, portable, path, but the first.

Is that the only data you’re seeing in home? Unfortunately the GPUCache is managed by electron and apparently can’t be changed. There is a workaround in the last comment of the link I posted but unfortunately it’s user level not app level.

Hopefully this is something that will eventually change, but knowing electron…

Okay. Makes sense. But that leads to a second question: Why is there a
/home/$(user)/.local/bin/Joplin.AppImage.home/.config/Joplin/GPUCache
?

Shouldn’t there be no such folder?

When there exists a Joplin.AppImage.home folder then AppImage will reset the $HOME environment variable to point to it. It looks like something weird is going on in Electron that is causing it to create a folder in the correct location, but when it writes it is using the home location obtained another way.

Can you try also creating a Joplin.AppImage.config folder next to the AppImage? Theres a good chance that electron is using $XDG_CONFIG_HOME when it decides where to write folders and creating this folder will reset it. Please let me know if that works.

You are right. Incorrectly, a /home/$(user)/.local/bin/Joplin.AppImage.config/ goes around the issue.

Now, I have no idea if this thread can be marked as Solved or not.