Home / GitHub Page

Android Joplin 1.0.179 / 1.0.181 not working - android 4.4

#1

Hello!

Using Joplin on Android I updated from 1.0.176 to 1.0.179. Starting lead to white screen.
Reinstalled 1.0.176, running fine again. Updated to 1.0.181 again only white screen after starting. Waiting for 25 minutes still white screen!
Did some of you know this behaviour? Whats wrong? I dont have many notes!

Greetings
Lucian

Android app doesn't work after update - Android 4.4.x
#2

Laurent said that this update takes time the first start because of the creation of indexes for the search engine

#3

Could you run un debug mode and check if there’s any error in the Console or log ?

#4

Hi Laurent!

Uninstalled. Reinstalled 1.0.181. No notes, no syn, starting leads to white screen again.
Console log from Android:

[ 12-20 21:53:11.328 11033:11063 I/ReactNativeJS ]

OPEN database: joplin.sqlite

[ 12-20 21:53:11.378 11033:11069 E/SQLiteLog ]

(1) statement aborts at 39: [CREATE VIRTUAL TABLE notes_fts USING fts4(content=“notes”, notindexed=“id”, id, title, body)] unrecognized parameter: notindexed=“id”

[ 12-20 21:53:11.378 11033:11069 E/SQLiteQuery ]

exception: unrecognized parameter: notindexed=“id” (code 1); query: CREATE VIRTUAL TABLE notes_fts USING fts4(content=“notes”, notindexed=“id”, id, title, body)

[ 12-20 21:53:11.388 11033:11069 E/unknown:SQLitePlugin ]

SQLitePlugin.executeSqlBatch: failed

android.database.sqlite.SQLiteException: unrecognized parameter: notindexed=“id” (code 1)

at android.database.sqlite.SQLiteConnection.nativeExecuteForCursorWindow(Native Method)

at android.database.sqlite.SQLiteConnection.executeForCursorWindow(SQLiteConnection.java:1035)

at android.database.sqlite.SQLiteSession.executeForCursorWindow(SQLiteSession.java:836)

at android.database.sqlite.SQLiteQuery.fillWindow(SQLiteQuery.java:62)

at android.database.sqlite.SQLiteCursor.fillWindow(SQLiteCursor.java:144)

at android.database.sqlite.SQLiteCursor.getCount(SQLiteCursor.java:133)

at android.database.AbstractCursor.moveToPosition(AbstractCursor.java:197)

at android.database.AbstractCursor.moveToFirst(AbstractCursor.java:237)

at org.pgsqlite.SQLitePlugin.executeSqlStatementQuery(SQLitePlugin.java:822)

at org.pgsqlite.SQLitePlugin.executeSqlBatch(SQLitePlugin.java:724)

at org.pgsqlite.SQLitePlugin.access$100(SQLitePlugin.java:49)

at org.pgsqlite.SQLitePlugin$DBRunner.run(SQLitePlugin.java:936)

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1112)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:587)

at java.lang.Thread.run(Thread.java:841)

[ 12-20 21:53:11.388 11033:11063 I/ReactNativeJS ]

warning - exception while invoking a callback: {“code”:0,“line”:1039,“column”:8354,“sourceURL”:“index.android.bundle”}

Thank you!

#5

What android version is it?

#6

4.4.2

#7

Same issue here. Previous versions worked fine. The app opens successfully and I can do pretty much anything except view notes. Whenever I click on a note I get a white screen.

edit: After some testing this only seems to be the case with synced notes. When I create a new local note on a fresh install there’s no white screen and everything works fine. As soon as I set up the sync target however, things start to break. I tried two different Nextcloud servers using both the Nextcloud and WebDAV setup and I always get a white screen when trying to open a note. What’s more, when I try to write to the server by creating a new note or notebook, the app crashes.

#8

Looks like FTS is not supported in these versions of Android. I thought it was but maybe not on all devices or something. I’ll add a check that disable FTS when not supported.

#9

Hello! Related issue here, but then with regards to my desktop version on Windows. I started to encounter these problems after the most recent upgrade. First I could not open synced notes, but could start new notes. However now Joplin only opens a white screen and freezes. Reinstalling does not work. Is there anything else I can try?

#10

Please open a separate topic and provide the debug log, which as you might imagine is needed to debug the problem.

#11

GitHub issue for FTS bug: https://github.com/laurent22/joplin/issues/1066

#12

Tested version 1.0.232. It’s running without problems again. Disabling FTS is the solution.
Great!
Thank you! :smiley::+1:

1 Like
#13

Hello Lucian! How do you disable FTS? There doesn’t seem to be a clickable option in the android app. I see only at the bottom of the configuration options : “FTS activé : 1”
Warmest greetings, Dimitri

#14

@Omniviator, FTS is automatically disabled on devices that don’t support it. Any reason why you want to manually disable it?

#15

Thanks for answering Laurent! It’s because it seemed to have resolved the sync issue. I have Android Version 8.0 and it syncs only the first 3 notebooks on the list. The sync between my Win10 and Linux systems works great by the way! :slightly_smiling_face:
Any suggestions? Warmest greetings!

#16

Is there any error message?

1 Like
#17

No, but it was buggy and extremely slow. I had a very long list of the tags, but no sync button at the bottom. I just reinstalled it and wait for it to sync again (Dropbox sync). I hope it works this time.
EDIT : A few hours later, same behavior : downloading only the first 3 from my 17 notebooks. :frowning:
Any suggestions Laurent?

#18

EDIT : A few hours later, same behavior : downloading only the first 3 from my 17 notebooks. :frowning:
Any suggestions Laurent?

Do you have the long list of tags in the sidebar at this point? I think that could be the issue, which I’ll try to look at next. I’m sure there’s a simple fix for this.

1 Like
#19

Thank you Laurent! Yes! I have a long list of tags. It’s from my Evernote imported Notebooks. I’ll wait for your fix! :slight_smile:

#20

I’ve now moved all the tags to a separate screen on the mobile app, which should mean some speed improvement for users with many tags. It will be part of the next iOS/Android release.

1 Like