Android 10 and MIUI 11 second space syn problem

My Version of Joplin is :
Joplin 1.0.201 (prod, win32)
Client ID: 4b9583efd77e4a949f77ecec8a70081c
Sync Version: 1
Profile Version: 28

Révision : e65af8c1 (master)
I am using Win 10 pro x64
Xiaomi Redmi 9S android 10.qkq1.191215.002 and MIUI Global 11.0.2

The facts :

  • Works well on Windows
  • Installed it on Android synchronized all is OK
  • Activated second space on Android
  • SET Joplin to work on both spaces
  • Synchronized Joplin from second space with another Dropbox account where I made a copy of the original Dropbox copy
  • Could never enter the passwords for decrypting the synchronized database
  • removed Joplin from second space (deactivating it in the second space app management)
  • Back to first space uninstalled Joplin ans cleaned remaining data via android 10 cleaning app
  • Reinstalled Joplin in the first space
  • synchronized from dropbox
  • Go to enter decryption pass
  • Cannot enter the pass (ie the save button does not work)

My question :
What could I do in order to “clean” android and reinstall from scratch ?
I think that the problem comes form Android, maybe not… have you any suggestion ?

Thanks in advance for your help and advises,
WBR,
Stéphane

Hi Joplin users,

Could please someone tell me the directories I have to look for in Android in order to clean correctly the previous Joplin install ?

Thanks in advance for your help,
Stéphane

Go to Settings - Apps, find Joplin and clear storage and cache.
You can’t access app data without root.

EDIT
Even if you do have root it’s better to do it as I described rather than trying to clean files manually.

Hi,

That is already done.
Then when I reinstall Joplin for android I can still not enter the decrypt pass (save button not working…
I’ve tried deleting the second space, removing the app, clean with android cleaner the remaining cache but nothing helps…

Could I export from My computer a backup from the data and copy them (manually to my phone ?
What backup format would you suggest and were should I copy the file in android ?

Thanks in advance for your help
Stéphane

I think there was an issue on github for that: https://github.com/laurent22/joplin/issues/3068

I don’t think it’s possible.