Home / GitHub Page

Where does Joplin store files on Android?

I use syncthing to synchronize files among the workstations and mobiles I use. After installing desktop on linux, I synchronized three workstations. So far, so good: whatever I do in one, it is reflected in the next one. Nevertheless, when I tried the same on Android (where I also have syncthing up and running), I can’t figure out how to force Joplin to find the directory where the files from the desktop are copied.

For instance, I inform on the designated field that the files are on /storage/emulated/0/Joplin (that’s where I have a full copy of the directory where Joplin stores its files on linux). Alas, it seems Joplin can’t find it.

Now I want to try something different, which is installing those files on the Joplin’s default directory. Bu then, where is it (in linux I’ ve found it ~/.config/joplin-desktop.

I’m using Syncthing between desktop and Android.
On the Desktop I’ve configured:

~/Documents/Joplin

as the store for the notes. Afterwards created a folder on the phones SD-Card, in my case simply called Joplin. You can create such a folder on your phone’s internal memory, in the case where you have no SD-Card, or just prefer to use the internal memory. Then create a two way sync with Syncthing between this folder and

~/Documents/Joplin

(or wherever it is you have your notes stored on the Desktop). After Syncthing has done it’s initial synchronization, then running sync on Android app should pull in your notes.

Is it your problem that you can’t point the Joplin Android app at your chosen location in the configuration? My folder on the phones SD-Card looks like this:

/storage/9A3C-17E1/Joplin

If finding the proper path name is your problem, perhaps you could install a terminal app on the phone and attempt using cd to track down the precise path the phone uses to end up in that folder?

Not sure I’m reading your question correctly? Any way good luck!

Johano, yes, you did read my question correctly. It seems you also have shed a lot of light on what I have to do.

First I had pointed to the SD card, but I had two different answers from Joplin. First one was that it could not write on the directory. Later, that it could not find the path. These two different error made me uneasy.

Then I moved to internal storage (for the time being, a have lots of internal storage available). Syncthing is doing what it is supposed to do. Nevertheless, Joplin can not see the directory. It is on /storage/emulated/0/Joplin I guess the path is correct since I can see it on any file navigator. Still, Joplin can’ t find it.

Fernando, have you checked the Joplin app under Android/Settings/Applications to confirm that Joplin has write permission?

Joplin-permissions

1 Like

Thank you, Johano. I am giving up. Yes, as far as I know, I have given permission as necessary. Nevertheless, Joplin still refuses to create a directory or even using an existing directory. On the other hand, it works on the default directory (the one created when I install or reinstall the app). But I can’t find where it is. If I could find it, I would use it to synchronize with the desktop files (using Syncthing).

Alas! No matter how hard I search, I can’t find the database.sqlite file.

I think perhaps this is due to your misunderstanding, you should not be syncing the database file directly (I believe @johano is not doing this). The better path is to choose a random folder on your android system and point the filesystem sync to this. Then sync that to your computer and do the same (use filesystem sync).
I can’t guarantee that your method works, but Joplin was not designed to be synced in that manner which means that syncing might irreversibly fail for you at any moment. You should use the proper built in sync.

1 Like

Your assumption is correct

1 Like

Caleb, I think you are right. On the three desktops I use, I have been synchrnizing the the equivalent directories (~/.config/joplin-desktop). This way, when I move from one machine to the next, the notes are already synchronized. I always make sure I stop Joplin in one machine before moving to the next. This way I know I will not have concurrency issues (so I hope).

But yes, I think I understood your point: it seems I should not do it this way, right? It seems you suggest I put the files on a different directory (not Joplin’s) and then point Joplin to that directory and let it do the sync.

Is that right?

If it is, then you are right, I am doing wrongly. Nevertheless, it still not working. From the first time I installed Joplin in Android, it has been working right. I can create notebooks, notes, etc. Alright. But I can’t make it synchronize. I have tried different directories, both on SD card and internal storage. I expected Jopin to use those directories, but it is not. It still has its own directory (which I have not been able to find).

Based on explanation, I would guess on Android I am doing the right thing, even thou I did not know it. But it still not working…

As to Linux, I think I should change the way I am doing it, even thou it is working…

I am lost, no doubt.

Finally got it running. I took the hints both of you gave me. Adding some more tinkering, sync is now working. I have a new issue, but this is a different thing and I will open up a new thread for this.

Thanks both of you.

1 Like