Where are notes stored? Linux Mint / .AppImage

Hi, I’m trying to find location of my notes in local filestem. Where are they?

1 Like

notes are all in the database for example on linux :


in the notes tables (select * from notes; to check)

and every files, images and so on , known under the named “resources” are


To get them easily (if this is what you want), you may choose "File system" for Sync' mode temporarily, then define a directory. Once Sync' is done, you get all your notes in that directory ! :wink:

1 Like

Or he could do this:


Much better, I agree…

After that I will have all data in two places?

Is there any way to change that default directories, so I can place all data in encrypted folder on my cloud and protect myself from reading my notes straight from database on local filesystem?

to change directory , start joplin with --profile /path/to/somewhere

1 Like

How might we achieve this while launching with the mac desktop application?

cd /Applications/Joplin.app/Contents/MacOS/
./Joplin --profile /path/to/somewhere


/Applications/Joplin.app/Contents/MacOS/Joplin --profile /path/to/somewhere


you can write a bash script, apple script, use automator, ...

Would be cool to have the notes in a data directory, not in .config


This will be very amazing. And the files should have their original names and just be saved as Markdown files.

+1 on keeping both database and the source markdown text files on a user-selected folder rather than buried in .config/home folder; my typical use case: Notes folder inside ~/Documents. Certainly more practical for backup purposes. Keeping separate .md files as the 'source' that the DB is kept in-sync with would also make the app more robust. Sqlite is probably very mature and reliable however a bunch but not as much as simple text files.

1 Like

Hi tessus, sir:
Sorry to bother you, but could you please tell me is there anything I can do to fix my Joplin 2.2.7 (prod, linux)? It seems that all plugins stop working when the .AppImage are executed with the parameter of “ --profile /path/to/somewhere”, even the “Plugins” section in the Configuration screen can display all of them.

I think you have to be a bit more specific. Also I am not sure I understand your problem. First you say that the plugins don't work and then you say all plugins show up.

If you install a plugin, it will be stored in the profile directory. If you start Joplin with the --profile parameter without moving or copying the profile dir, a new profile will be created with default settings and no plugins.

Thank you very much for the reply. This is how I found this problem:

  1. Run Joplin with —profile at the first time
  2. Install plugins in “Plugins” section then restart

The plugins I installed shown up in both “Plugins” section and the plugins directory under the profiles directory, but none of the plugins works.

Did I make it clearer?

Not really. Without log files or some other information this is impossible to figure out.

What are the specifics? Which plugins are not working? Pick one and ask the dev of the plugin to help.

Very appreciate for your time! Thank you!
I’ll try and see what I can do.

tessus, I think I found the reason. It was the path.

I checked this:

When I ran the .AppImage file, I used this precise command line: “./Joplin.AppImage —profile ./joplin-desktop”. And I found some errors like “GET file://./joplin-desktop/something net::ERR_FAILED” within the console, I assumed that Joplin was looking for something out of the current working directory in which I expect everything should take place.

So, I tried to assign the full path instead of just “./joplin-desktop” to .AppImage. Lucky me, everything went well after that.

Besides this, I’d like to say “thank you” to you and all others from the Joplin team. Great work! Thank you very much!

I'm glad everything works now.