"Unknown field: fetch_error" on first iOS sync

Just downloaded OSX desktop app. Enabled encryption and Dropbox sync. Synced.

Installed iOS app, and tried to sync. I get:

Fetched items: 214/477
Completed: …
Last error: Error: Unknown field: fetch_error

Happens all the time. Cannot get the iOS version to sync. Never asks me for a password and automatically turns on enc, per the instructions. Tried removing app, reinstalling.

If I view the encrypted files on dropbox, I see that type_ 4 *.md files have a fetch_error field.
No “fetch_error:” has any error.

252 of the *.md files are type_: 4, and all have the fetch_error: field. No other *.md file has a fetch_error:

There are 463 total *.md files on the host, as well as on the iPhone DropBox/Apps/Joplin folder.

Every time it fails to sync, and is restarted, it starts over fetching all the files.

Just installed it on my iPad. Exactly same behaviour.

I suspect this happens because the iOS version is older than the OSX desktop app. ( It does not seem that Joplin 1.0.114 is available in App store yet ),

I upgraded my Android version to 1.0.114 yesterday and the result is that Sync is broken on my iOS Joplin.

Same error : “Error: unknown field: fetch_error”.

I had the same error on W10 desktop this morning but upgrading that to 1.0.114 fixed the problem on W10.

So I guess we’ll just have to wait a bit until 1.0.114 shows up in App store)

I have the new IOS version.
It seems to get past the sync issue. However, whenever I attempt to enter the password, it crashes.

Hmm. Pretty much any interaction with the App will cause the UI to freeze and eventually it crashes.

For example: Start App fresh. Touch the top right most gadget. A menu “Delete notebook // … Enc Config // Config” pops up. No further interaction is required, it crashes.

Actually, I suspect it may be crashing in “synchronisation” still. Fresh restart; touch top-left-most gadget. See sync status. Do nothing else. Wait less than 60 seconds and it crashes again.

I turned on AirPlane mode, and the App stays up long enough to turn off sync.
I can then add the decrypt passwd to 3 of the received master keys. One master key still apparently has not been received.
I pretty much have only one item in one notebook. I do have a huge # of orphaned resources as when this initially happened, I deleted all the items I have imported from Evernote. There are over 200 resources, all orphaned.

It would be good if there was a “show orphaned resources” screen (on the desktop app) which would list all the resources which are orphaned and allow me to sort the list (perhaps by creation date) and then select some and purge them.

I know for sure that all the resources are orphaned.
If you look at the Anki App, it has the ability to show me a list of orphaned resources and it permits me to purge them. My guess is that there is some issue with one of these orphaned resources which is killing the IOS app.

@permezel, any chance you could provide a crash log as described there? https://joplin.cozic.net/debugging/

I snarfed the log.
I cannot mail it because I keep getting bounces for “unexpected reply address”.
I cannot upload it here: “Sorry, the file you are trying to upload is not authorized (authorized extensions: jpg, jpeg, png, gif).”

@permezel, thanks for the log but unfortunately it doesn’t say much about why it’s crashing. On the sync target, in the .resources folder, do you have large files like 5MB or more?

Hi Laurent.
I do have some large resources. They are duplicated because I added, then deleted, then re-added.

When might I expect the orphaned resources to be deleted?

I have lots of space on the phone. I removed multiple gigs the other day just to add even more free space.

  5279613 29 Oct 11:59 0f861cb828bb4fddae9ab45d74435ecc
  5279613 25 Oct 15:06 082d5f04050fd0fe12aff6e93e1dd6b5
  7796261 29 Oct 12:02 daa1b30a0ece4933b29bff17dd21e258
  7796261 25 Oct 15:01 3d5468dfd810a34646bf7b57180abe20 
 30944789 25 Oct 15:12 71127827bacd6a29a630fee747ab8346
 30944789 29 Oct 12:05 6730964131d743ac9bcf287d1487f1a2

Here are the matching files:

   2917490 25 Oct 13:11 082d5f04050fd0fe12aff6e93e1dd6b5.pdf
   4308224 25 Oct 13:11 3d5468dfd810a34646bf7b57180abe20.png 
  17100240 25 Oct 13:11 71127827bacd6a29a630fee747ab8346.pdf

These resources appear to relate to items in the Trash of EverNote when I exported it.

Would be good to advise to empty trash prior to export/migrate.

It’s not a matter of space on the phone but a bug in one of the modules used by Joplin that’s causing it to crash when transferring files over 10MB or so.

What you could do is locate these resources on the sync target and manually delete those over 8-9 MB. Make note of the IDs, then delete the associated .md files.

For example, if the resources is “0f861cb828bb4fddae9ab45d74435ecc”, delete the file “.resources/0f861cb828bb4fddae9ab45d74435ecc” and then the file “0f861cb828bb4fddae9ab45d74435ecc.md”. Then sync again and it should work.

On a recent change, I’ve improved how resources are downloaded, which will eventually allow better dealing with this kind of issue, but in the meantime it requires a bit of manual work.

Thanks. I’ve decided to use Notes.app for my EverNote replacement.
Missing a nice export/import, but for my currently intended uses, seems adequate.