Unable to decrypt resources anymore

Hi there,

I had a few issues with the master key upgrade recently it all went down to the rabbithole, so I decided to take a backup of my notes BEFORE. I restored it, everything went fine but for the resources. Joplin is not able to decrypt them although it works for the notes.

I tried with Android, Desktop Joplin (Fedora 31 1.0.197), Terminal Joplin (Fedora 31 1.0.162).

In Desktop I can click “retry” on the resources but it never works.
In Terminal if I click the link of a resource, it redirects me in the browser (as expected), saying it cannot find the file (and I checked the mentioned path, and indeed the file is not there).

how did you take a backup? and do you still have the originals somewhere safe?

My notes are synchronized on Nextcloud which is backed up every night.

Yes I can still access old backups.

Backing up the sync target is not quite the same as taking a backup of your notes. For future information, the recommended backup is to export to a jex archive, you can use the terminal app to automate it.

How did you restore the notes? Did you completely wipe joplin from your drive and start again? Or did you just replace the notes at the sync target?

If you did the latter, then this is to be expected since Joplin only downloads resources once and doesn’t re-sync them (This applies for pushes, so I don’t really know what the logic is on the download side).

If you did wipe the local installation, can you check the ID’s of the items you’re having trouble with. And then check if those files exist on your sync target/backup?

1 Like

How is it different from using a Jex archive? I mean if I have the full content of what is shared between my different instances (phone/desktop), how is it different ?

I did wipe the entire installation and everything living under ~/.config/joplin ~/.config/Joplin and ~/.config/joplin-desktop before re-initialising.

I checked, every single one of the ID’s is existing in the .resource folder.

Simple answer: the JEX archive is a local snapshot that can be used when something happens causing all of your devices to lose data or your content to become corrupted. Because JEX archives aren’t tied directly to syncing and are simple zip archives, you can simply remove Joplin and all of its config files and just import your Jex file back into Joplin. Backing up through your syncing service doesn’t allow you to have a fully decrypted backup either in case something happens and you’re locked out of your notes.

I hope this gave some insight and answered your question pretty thoroughly. :wink:

Thanks for your answer about the Jex archive. Altough I do understand the idea, I’m not sure that having unencrypted backups is something I would want.

1 Like

The main benefit is that if something goes wrong with the sync target, it’s easier to restore from a single location. You still have the option to encrypt your jex backup however you want…

Do you have older backups of the resource files that you can try to recover from? It’s looking to me like the sync files have been corrupted somehow. There aren’t any reasons that the client would refuse to sync across all those devices.


Just to be clear, the synching by itself is working, I do have those files on every devices, but Joplin is unable to decrypt them while it’s able to decrypt the notes.

I have older backups and I already tried, with backups from February for instance, and the issue still is here.

I’m wondering if it could have something to do with the new decryption keys, by that I mean the introduction of the upgrade of master key introduced recently.

It’s almost certainly something to do with the upgrade. I don’t know the specifics of the upgrade so I can’t help you debug how it might have failed. It seems possible that the files you’re having issues with weren’t upgraded though. You might have some success using an older version maybe v1.0.195 will be enough.

It worked…

Thank you very much, I’m trying to upgrade the key again right now, but was able to recover all my data.

I chose your answer as solution. Do I have something else to do ?

If I were you I would take a temporary jex backup before making that upgrade :slight_smile:

Thanks for confirming the fix, nothing more is needed. Please enjoy having your notes back!

I’m in the same situation. Tried 1.0.95 but didn’t worked. Should I try older and older versions till something works?

Aside of that, i would like to understand why resources can’t get decrypted while there’s no problem with notes.


I only got out of the situation by restoring backups, decrypting them with an old version and keeping them unencrypted.

As to why it’s not working properly only for resources, maybe this is a size issue but cannot answer myself.

I’ve looked at logs, can’t decrypt because the “.crypted” file pair is not even present in the db or the synced folder. So, seems that somewhere in the time sync went wrong and my resources where lost.

Lucky me, most of my notes are simply text, and I’ve rebuilt those notes with images using the web clipper (yes, I do use clipper as offline website bookmark). Love the webclipper.

I’m gonna let another chance to the new version.

Thank you.