Type:todo search doesn't work on mobile

Operating system


Joplin version


What issue do you have?

Filtering for all todos isn't working for me on mobile, which is unfortunate since I also don't have access to the agenda plugin there, so there isn't a way to see all tasks in one place.
It seems to return every note in the current sorting order, so not doing any kind of filtering; I had to scroll down quite a bit to find a todo for the screenshot.
The first screenshot is from my desktop doing the expected behaviour (though it would be nice if there was a way for completed todos to be sorted to the bottom of the list) and the second screenshot is from my phone.


I think it works but in the first screenshot you have enabled the option to show completed to-dos while in the second they are hidden. You can show them by clicking on the filtering button in the top right corner

No, I saw that option but the issue is that on mobile all the notes I blocked out aren't todos at all. So not completed or uncompleted todos just normal notes, so they should be in the list.
I also have the option of having uncompleted todos on top ticked in both versions but it doesn't seem to be making any difference

Ok i think that's because I'm on 2.13, and it's been fixed recently. So the next release in about two weeks should fix it for you too

Oh, that's great!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.