The attachment file content is not synchronized after modification, please assist

After modifying the file content of the attachment on the computer, open the content of the old attachment on the mobile phone, and the attachment content is not synchronized after modification


1 Like

Unfortunately that is a current limitation of Joplin. If you really need to modify a file you’ll have to save it somewhere else and re-attach it.

1 Like

Can this question be included in subsequent optimization projects? thank you

I’m not sure exactly what you’re asking. But if you’re asking that we add that feature at some point, then for sure it is something that will be done eventually. I actually tried once, but it’s rather complicated.

1 Like

After opening the attachment and editing it, the edited attachment cannot be synchronized. I hope it can be added to the optimization project so that the attachment can be synchronized after editing. Thank you

We can do something like adding a background service which keep tracks of synced attachments and if there's any change in attachment (change in "last modified date" metadata) then it will re-sync that note with edited attachment.. just a thought....I'm not sure if it works :sweat_smile:

1 Like

The modified attachments cannot be synchronized, which is the biggest problem I encountered when using Joplin. Thank you for your suggestions, and I look forward to the development team having a good solution.


Yes absolutely, the structure could be similar to the external editor.
Another option is to mark any opened attached as dirty by adding a hash of the attachment. On sync the dirty attachments would be checked against the hashes and the changed ones could be synced. This would avoid the necessity of running a background service.


Yes that would be more efficient and robust...but could be a tough implementation :wink:

Does the development team see this problem? Can it be solved? Thank you

Just to chime in on this - as a new Joplin user, loving it but very surprised that changes to attachments are not synching, and there doesn’t seem to be a way to force that to occur. Add my vote to finding a solution for this, please!

1 Like

The inability to synchronize after the attachment is edited is a major defect of Joplin, and I hope that the development team will fix it first after seeing it. Thank you

Looks like this feature was just merged in a couple of days ago. Please be patient it should be available soon.

1 Like

Great, thank you very much.

I recently discovered and migrated to Joplin (1.4.19, Linux), which does everything I need to do, except synchronising attachments properly. Googling for this led me to this thread.

Would someone please update on this issue ? Is there a workaround if it is not fixed yet ?

Thank you in anticipation.

Hi @ChristopheDavid

As far as I know there aren't any known issues with this feature. If you have encountered an issue please open a new thread on the forum that describes your problem in more detail.


1 Like

Thank you for the fast reply.

After checking, it looks like everything works fine for new attachments.

What I had noticed is that after I turned on encryption and shared the synchronisation folder using SyncThing, when importing on a new device the notes were encrypted properly but the attachments were lost.

Since then (no new configuration change), new attachments are shared correctly.

Not sure it is worth a new specific topic, but maybe something to double check in the future.

Thanks again for your help and for this very useful piece of software.

This doesn't seem to work for PDFs? I have just changed a PDF and synced, then on my other devices started a sync, but on the other devices, the PDF is still the 'old' PDF. Is there a way to force-sync attachments?

Can you confirm which version you're on? And which Os.

When you open a pdf from a note, there should be a big message that appears across the top of Joplin, do you see this?

Yes, that's what I see when I open the PDF by clicking the link.
However, I needed it to open with a different PDF editor, and Joplin has no 'Open with...' menu-item so I right-clicked the PDF-link, choose 'Show in Finder' and edited the attachment there directly.