Text of notes is garbled in macOS (intel) client version 3

Operating system


Joplin version


Desktop version info

Joplin 3.0.12 (prod, darwin)

Client ID: 4d6f946e4b1f418f843bb4e5ffabe27f
Sync Version: 3
Profile Version: 47
Keychain Supported: Yes

Revision: a64d6e3

Backup: 1.4.1

Sync target


What issue do you have?

After updating to version 3.0 on macOS (intel), the text of notes is garbled (see image below). The notes appear fine on both the Android and iOS clients, so this appears to be only a display issue, and not a problem with the files.

Do you want me to open an issue on github, or is already being worked on?


Well that is certainly an interesting development...

Out of pure curiosity, does it display normally in the richtext editor?

Either way I think it probably deserves a bug report on GitHub, I'm not aware of an existing one but we can always close or merge if needed.

The two editors are shown side by side in the image above.

I found that if I enable the "macOS theme" plugin that everything works, but that when the macos theme plugin is disabled, the text in the rich text editor os garbled.

The image only shows the markdown editor and viewer though? Not the richtext editor (the switch in the top right).

I'm now thinking this may not be a Joplin bug in itself if you mentioned the plugin interacting with this.

Can you launch Joplin in safe mode and confirm if it still shows?

The behavior is the same in the viewer and the richtext editor.

If I relaunch in safe mode, I'm only given the possibility of editing in markdown mode, and there is no option to see the view mode or to use the richtext editor. In markdown mode, everything is fine.

Sorry, I forgot safe mode disables text rendering. Basically I want to rule out plugins and styles without making you rip your whole profile apart.

In the help menu there should be an option called "Copy dev mode command to clipboard". If you use that it will, as the name implies, copy a command into your clipboard. If you then paste that into a terminal or similar it will launch a second instance of Joplin but independent of your main profile (i.e. it will have no plugins, no stylesheets, no notes and default options). Can you do that and see if the issue remains?

When I do that, it appears that the problem is worse. Now the text is garbled in both the markdown editor and viewer.

Well that is even weirder, might be worth adding that detail to the issue if you could.

It turns out that the exact same problems exist on a different macOS computer (this one, on apple silicon).

This is a major bug, and it is clear that the application wasn't tested on macOS. Could you please ask one of the developers who have a macOS computer to look into this?

I mean, @Laurent himself works on macOS and I don't think anyone would have developed or tested it on macOS more than him...

Also, if this was universal we would have seen more than just one report of this - over 15.5k downloads of the mac builds have been made already.

For the record, here is a screenshot run in developer mode on macOS (M1 Max, apple studio). This is an independent computer, and it is on a different network than the previous one.

Indeed I'm running the macOS version without any issue. Is it possible that your system fonts are corrupted? Is there maybe some way in macOS to restore or repair broken fonts?

Also have you tried changing the editor fonts in the settings? Does it do this with all the fonts or just some of them?

Edit: I don't have an M1 so that could be why it works for me. On the other hand if there has been 6.9k downloads of the M1 version and only one report it seems it's not a general issue

Edit: wait, do you mean you tried on two different computers, one Intel, one M1 and you got the same results on a new install?

Yes, two computers: one intel and the other an M1 Max. They are on different networks. One is a personal laptop, the other is a workstation at work. The M1 max is brand new, and I have not done anything funny with the fonts since setting it up.

Could you try disabling the "macOS theme" plugin? Some of these problems (but not all) go away when this plugin is activated.

same here - just upgraded and all my text is garbled.

I was able to fix the markdown window by selecting specific fonts in settings, but the rendered text is still garbled...

if I copy/paste then it comes out correct - so it's clearly a case of it selecting the wrong font to render...

I've not tried the built version yet (I've got a whole bunch of clients I need to upgrade first) but on my geriatric intel mac mini all looks OK from the dev build.

The default font for the rendered markdown pane seems to be Avenir (with a fallback to Arail or sans-serif if Avenir is unavailable). Does changing the rendered Markdown font to sans-serif help? For a single note, this can be done by:

  1. Opening the markdown editor.
  2. Adding the following to the end of the note:
        #rendered-md {
            font-family: sans-serif;

If that works, does it still work if font-family: sans-serif is replaced with font-family: Avenir?

Note: I haven't been able to reproduce this locally (MacOS Sonoma 14.5, Intel, new profile with all plugins disabled).

yes! That works if I set font-family to sans-serif but not if I set it to Avenir...

Does 'Avenir Next' (with the single quotes) work? If so, it could make sense to change the default font list to 'Avenir Next', 'Avenir', 'Arial', sans-serif.

1 Like

It turns out that using "Avenir Next", "Arial", and sans-serif work, but "Avenir" doesn't.

Based on this, I've opened a pull request with a possible fix:

Do websites that use Avenir also have this issue in Chrome or Chromium-based browsers? If not, upgrading Electron to v31 might also fix the issue.

Thank you for reporting this!