Home    |    GitHub Page    |    API    |    FAQ

Tests fail

Currently several tests fail. I suspect it has something to do with the lerna changes.

Unfortunately the tests still fail:

Failures:
1) services_SearchFilter should support filtering by between two dates
  Message:
    Expected 1 to be 2.
  Stack:
    Error: Expected 1 to be 2.
        at <Jasmine>
        at asyncTest (/Users/tessus/data/work/joplin/packages/app-cli/tests/services_SearchFilter.js:394:23)
        at process._tickCallback (internal/process/next_tick.js:68:7)
  Message:
    Expected [ '45d102d3dec148eb892bdf5052ef28a0' ] to contain 'add9a662407e4d299537dea57a05815e'.
  Stack:
    Error: Expected [ '45d102d3dec148eb892bdf5052ef28a0' ] to contain 'add9a662407e4d299537dea57a05815e'.
        at <Jasmine>
        at asyncTest (/Users/tessus/data/work/joplin/packages/app-cli/tests/services_SearchFilter.js:395:21)
        at process._tickCallback (internal/process/next_tick.js:68:7)

I must have rebroke it when fixing the search bar, I'll check.

Hmm, no it's either already fixed or it's random as it's not happening for me. What was the random seed?

The random seed was: 94236

I just tried again and it happened again with 20213 and 92132

Still works for me. Maybe some timezone related issue as sometimes things work for me just because I'm in UTC. Could you travel to a different country and try again? :slight_smile:

hmm, the CI pipeline is broken, thus you can't even see the test errors in travis.

Very strange. The tests certainly don't work on my local machine.

My guess is that the way the test date is created and the way it is parsed by the search engine is different. Maybe one use local time, and the other UTC, but I'm not sure. Perhaps @naviji would have some idea?