Tailscale + CasaOS + Joplin Server

Operating system

Linux

Joplin version

2.14.20

Desktop version info

2.14.2

Sync target

Joplin Server

What issue do you have?

Hi All

A bit about my set up before I begin, I have a raspberry pi at my house running CasaOS (its like a GUI on docker) its aimed to make self hosting easier for novice users (which is me). I have installed Joplin server on CasaOS from the App Store and have it running fine.

I also use Tailscale to expose the server (CasaOS) to the internet without the hassle or risk of port forwarding.

Tailscale has a "Serve" option where It can expose nodes services to the rest of my tailnet, I have enabled this via the admin console and it has provided a https address

  • I am able to access CasaOS through tail scale outside my network which works fine on (public ip:port number)
  • I am able to get my Joplin programs to sync providing they are on the local network using (Local ip: port number)

My problem comes when I try to sync my Joplin installations to the Joplin server using the https address I get the generic error 502 bad gateway (both machines are on the talent) I'm not sure what I'm missing so I'm wondering if anyone else has used this method of getting a Joplin server up and running?

I know this is a meaty one and perhaps best for Tailscale (which I will reach out to as well) if you need anything clarifying just ask

Any help would be great