Joplin server sync problem

Hello,
I am using on my network without problem for both mac and iphone.
For public, I forward my domain to my home IP and did adjustments with nginx.
(I did with some other apps, they work perfectly.) But joplin doesnt sync.
server on raspberry pi. (server-v2.7.4)
I tried remove and reinstall for both (docker and iphone.)
I tried most of combinations like:
x. x. com
x. x . com:22300
ht t p : / / x . x . com
h t t p:// x. x . com : 22300
(oh cant type domain address, so I am changing msg.)
2022-09-18 22:43:17: [error] App: 404: GET /: 192.168.1.254: Invalid origin: h t t p: / / x . x . com
2022-09-18 22:43:17: App: GET / (404) (2ms)

And on the phone side it turns always or network request failed, api/sessions error, sometimes shows synced but it doesnt.

Do you have any suggestions?

Please provide your docker-compose.yml file and your nginx reverse-proxy configuration.

Hint: Embedded in ` (or via the options, preformatted text), you can post as many links as you like.

"com.docker.compose.config-hash": "a8857bf0b50ea836ac6a7709404988cdaa023a4c9a7c25486ffe92eb7d347c3a",
                "com.docker.compose.container-number": "1",
                "com.docker.compose.depends_on": "",
                "com.docker.compose.oneoff": "False",
                "com.docker.compose.project": "joplin",
                "com.docker.compose.project.config_files": "/data/compose/45/docker-compose.yml",
                "com.docker.compose.project.working_dir": "/data/compose/45",
                "com.docker.compose.service": "app",
                "com.docker.compose.version": "2.5.1",

And I tried with 2 different of my domains. One of them without SSL other one with SSL (I am not sure about SSL settings) ( I wrote just joplin . domain . c om too but not working, also on my router both 80 and 443 routed to nginx)

This is not the docker-compose.yml, that looks something like this: joplin/docker-compose.server.yml at dev · laurent22/joplin · GitHub

Or if you don't use compose, your .env file...

sorry couldnt find the file.
this one:

(https://hub.docker.com/r/florider89/joplin-server)
version: '3'
services:
    app:
        environment:
            - APP_BASE_URL=http://joplin.yourdomain.tld:22300
            - APP_PORT=22300
            - POSTGRES_PASSWORD=joplin
            - POSTGRES_DATABASE=joplin
            - POSTGRES_USER=joplin 
            - POSTGRES_PORT=5432 
            - POSTGRES_HOST=db
            - DB_CLIENT=pg
        restart: unless-stopped
        image: florider89/joplin-server:latest
        ports:
            - "22300:22300"
    db:
        restart: unless-stopped
        image: postgres:13.1
        ports:
            - "5432:5432"
        volumes:
            - /foo/bar/joplin-data:/var/lib/postgresql/data
        environment:
            - POSTGRES_PASSWORD=joplin
            - POSTGRES_USER=joplin
            - POSTGRES_DB=joplin

(It looks like you're only using http instead of https? I would encourage you to you the second one.)

The APP_BASE_URL has to be only http://joplin.yourdomain.tld and the reverse proxy (double check if it's really a reverse proxy?) has to forward everything from this domain to IP:22300.

Not with nginx, but maybe this guide will help you further, too: