Home    |    GitHub Page    |    API    |    FAQ

Table Rendering Problem

version : 1.0.178
OS : windows 10

I’m working on some chinese note with table on Joplin, I found some table rendering problem. the same text, when I try to preview in Joplin, it still text, when I using the same text rendering in VS Code, seem it’s normal, I’m not sure it is bugs or not, or maybe chinese character problem? please advise.

Additional information : no userstyle.css or userchrome.css apply

Seem I found some problem : if no space before the table, the table is render correctly, if table is indented. it will show plain text.

It’s interesting that it renders in vscode correctly! But glad to see you solved the problem.

actually not solved. I just removed the indent :sweat_smile:

I think probably the markdown renderer that joplin uses does not have this capability, you can probably file a bug with them if this is important for you, otherwise i think removing the spaces is a good idea.

I’m not sure it’s bug or not :frowning: maybe just my personal preferences. However, I’ve try to indent the image, text under the list and the indentation can render correctly.

If you don't need the multimarkdown table extension, try to disable it.
Joplin 1.5.14 correctly render indented table if i disable the multimarkdown table extension.