Home / GitHub Page

Syncronization with nexcloud

#1

Hello,
I configured joplin on my android smartphone and my linux PC and it’s work great but now I’m trying to set up on my windows PC and I can’t connect. How to do this ?
the error :
request to https://XXXXX/remote.php/webdav/xxxx/ failed, reason: connect ETIMEDOUT 213.186.33.40:443 (Code ETIMEDOUT)
Thank you in advance

#2

hi and welcome
which joplin version do you use ?

#3

I use Joplin 1.0.151 (win32)

#4

The log file :

2019-05-13 11:53:42: "La synchronisation est déjà en cours. État : in_progress"
2019-05-13 11:58:42: "RevisionService::maintenance: Starting..."
2019-05-13 11:58:42: "RevisionService::maintenance: Service is enabled"
2019-05-13 11:58:42: "Running background sync on timer..."
2019-05-13 11:58:42: "Scheduling sync operation..."
2019-05-13 11:58:42: "Preparing scheduled sync"
2019-05-13 11:58:42: "Starting scheduled sync"
2019-05-13 11:58:42: "RevisionService::collectRevisions: Created revisions for 0 notes"
2019-05-13 11:58:42: "RevisionService::maintenance: Done in 114ms"
2019-05-13 12:00:38: "FetchError: request to https://XXXXXX.XXX/remote.php/webdav/Joplin/.sync/     failed, reason: connect ETIMEDOUT 
Code: ETIMEDOUT    
FetchError: request to https://XXXXXX.XXX/remote.php/webdav/Joplin/.sync/ failed, reason: connect ETIMEDOUT
at ClientRequest.<anonymous> (C:\Users\lucas.rivoirard\AppData\Local\Programs\Joplin\resources\app.asar\node_modules\node-fetch\index.js:133:11)
at ClientRequest.emit (events.js:182:13)
at TLSSocket.socketErrorListener (_http_client.js:391:9)
at TLSSocket.emit (events.js:182:13)
at emitErrorNT (internal/streams/destroy.js:82:8)
at emitErrorAndCloseNT (internal/streams/destroy.js:50:3)
at process._tickCallback (internal/process/next_tick.js:63:19)"
2019-05-13 12:00:38: "Operations completed: "
#5

If you type the exact url in a web browser, can it connect?

https://XXXXXX.XXX/remote.php/webdav/Joplin/.sync/
#6

Yes I can connect in a web browser but I have this message :

This is the WebDAV interface. It can only be accessed by WebDAV clients such as the Nextcloud desktop sync client.
#7

Did you do this on the Windows machine? The reason I ask is that the error message you received hints that the connectdion to that server or address is blocked. Why would you receive a timeout otherwise?
IMO a personal firewall or Windows blocks something.

#8

Yes I did it on my windows machine and it works.
So I don’t understand why it doesn’t work on Joplin application …

#9

Right, I’m not sure I understand this either. On macOS I use LittleSnitch, where I have to allow applications to connect to remote resources. Maybe you use something similar on Windows.

But I believe there was a sync issue with 1.0.151. Could you try with 1.0.152?

#11

@laurent Do you have some more insights? I am really not the person to help with Windows issues. What would be a reason for a ETIMEDOUT error code.

P.S.: Maybe I should setup Windows in a VM and start looking into Windows again.(I don’t even know how to buy a Windows copy.) The last time I installed Windows was NT Server 3.1 or 3.51.

#12

I don’t know but it’s not a bug in Joplin. It’s just a timeout probably due to config error, firewall like you said, or something else.

#13

Maybe a problem with cert validation?

#14

How can I verify that there is a certificate problem?

#15

Can you try a non-https url?

Instead of

https://myserver/remote.php/webdav/...

use

http://myserver/remote.php/webdav/...
#16

I have exactly the same error with non-https link :disappointed_relieved:

#17

Maybe check your proxy settings? If your computer is at work, there’s a good chance some proxy is involved somewhere.