Syncing problem on Android 10 and the solution

I use Syncthing to sync Joplin between devices and it was working great under Linux and my Android 10, but after a new Android 10 "Lineage" fresh re-install, I started to get this error "joplin could not read directory", I did not touch the Joplin directory and the app has all the permissions, but I noticed that the same error always present with or without the "Storage Permission"!

So, installed "Permission Manager X" and gave Joplin the permission for "LEGACY_STORAGE AppOps, UID mode", and error is gone, the app is syncing just fine now.

I'm sharing this to help resolve this issue and for Joplin team to look into it.

Thanks @mmBesar for this solution. I have managed to recreate the same error and solution on my Android 10 device. Joplin was syncing fine on Android 9 for me. After I upgraded to Android 10 (Lineage OS), I had the locks folder syncing error in Joplin. I also sync across to Linux using Syncthing. I tried your Permission Manager X solution and it did the trick for me.

1 Like

Glad, I could help.
Thanks for the feedback.