Synchronization with cloud (pcloud) failing

Version: 2.7.15
OS: Xubuntu 18.04
Synchronization with pcloud service using webdav was failing.

Hi, relatively new user here. I hope this is the correct place to post my observation.

About 1 month ago my sync with pcloud stopped working. I finally noticed it and resolved it today and hope this may be useful for someone. I noticed that there was an unresolved support topic related to this previously that was closed.

My sync was failing with an permissions error - failed to access info.json

Looking at the info.json file in the browser through webdav, I received the same error.

Looking at the file through the command line using the pcloud app I noticed that it displayed like this:

chris@laptop1:~/pCloudDrive/joplin_sync$ cat info.json
"version": 3,
"e2ee": {
"value": false,
"updatedTime": 0
"activeMasterKeyId": {
"value": "",
"updatedTime": 0
"masterKeys": [],
"ppk": {
"value": null,
"updatedTime": 0

Notice that the last line ran into the following command prompt.

I edited the info.json file and simply added an extra blank line at the end and the sync process burst back into life.

I hope that this helps someone.


We don't currently support pcloud:

Thanks for letting me know. I will turn off sync in Joplin and copy my jex backups to pcloud as part of my daily file backup instead.
Thanks again

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.