Problem of syncronisation on linux and android

Good afternoon members!
I have an issu of synchronisation, both with Joplin on my linux (ubuntu 22.04.1 LTS) and android. The problem started 2 or 3 weeks ago I think (maybe little more?)
Here the 2 messageswhen I try to update the syncronisation:

message 1:

The full error was:

GET info.json: Unknown error 2 (403): 403 Forbidden

Forbidden

You don't have permission to access this resource.


Apache/2.4.38 (Debian) Server at ewebdav.pcloud[DOT]com Port 443

Error: GET info.json: Unknown error 2 (403):

403 Forbidden

Forbidden

You don't have permission to access this resource.


Apache/2.4.38 (Debian) Server at ewebdav.pcloud.com Port 443
at newError (/snap/joplin-desktop/30/opt/joplin-desktop/resources/app/node_modules/@joplin/lib/WebDavApi.js:414:11)
at WebDavApi.exec (/snap/joplin-desktop/30/opt/joplin-desktop/resources/app/node_modules/@joplin/lib/WebDavApi.js:444:10)
at process.processTicksAndRejections (node:internal/process/task_queues:96:5)
at async FileApiDriverWebDav.get (/snap/joplin-desktop/30/opt/joplin-desktop/resources/app/node_modules/@joplin/lib/file-api-driver-webdav.js:164:21)

message 2:
Terminé : 23/01/2023 13:37 (20s)
Dernière erreur : Error: GET info.json: Unknown error 2 (403): 403 Forbidden

Forbidden

You don't have permission to access this resource.


Apache/2.4.38 (Debian) Server at ewebdav.pcloud[DOT] com Port 443

Do you know what I can do?
I don't understand why it say I don't have permission to access. The password is the correct one.
Thomas

@thomas1 welcome to the forum.

If you search this forum for pCloud you will see that issues like this occur a lot. As I understand it pCloud use a WebDav implementation that does not appear to be compliant with WebDav standards and so is somewhat unreliable.

I believe that it is for this reason that Joplin lists pCloud as an unsupported WebDav host.

I wonder if we should add a check in Joplin to immediately stop sync when pcloud is detected. This service appears to be quite popular but they have a broken WebDAV implementation, and it doesn't look like they plan to fix it

It's now in the backlog:

The suggestion in the issue seems rather provider specific :slight_smile: There's another unsupported provider and there may be more in the future. It's also possible that some may later get their act together and provide a better WebDav service. It could be that you would have to add / remove options from advance settings whenever things changed.

What about if upon entering the URL in the sync server field Joplin justs checks the domain against an internal "unsupported webdav" text file and shows an unmissable generic warning if the domain is on that list. I was thinking like the greyed out settings screen when setting up encryption.

This also means that domains can be added to or removed from the "unsupported webdav" list without having to refactor Joplin itself.


Alert Mockup

Hello,
Thanks for your message.
here the message I sent on github. sorry if I was not good to post on both forum.

I'm not sure if my message helps, but just in case. I am a pcloud user, so I contacted pcloud support. For them the problem comes from joplin, because via a browser for example, you can use the pcloud webdav (which is true for connecting to the webdav via a browser, but no idea if that means their webdav really works).
Have a nice day, and thanks for your collective work!
Thomas