Synchronisation by webDAV failed on both Android and Mac

I’m running a Joplin 1.0.175(prod, darwin) on Mac and Joplin 1.0.132 on Android.
I have been trying to sync by webDAV using Nutstore. WebDAV configuration checking worked well, but sync always failed, creating 3 folders on my Nutstore cloud – “.lock”,".resource" and “.sync” with a text file “version.txt” in the folder “.sync”.
Also, logs appeared on Android and Mac were that:
" Created remote items: 1.

Completed: 24/12/2019 02:04

Last error: Error: PUT 8647dc0f397e42be930afb5ca5577fec.md: The resource of this location does not exist (Exception ObjectNotFound) (404): <?xml version="1.0" encoding="UTF-8" standalone="no"?><d:error xmlns:d=“DAV:” xmlns:s=“http://ns.jianguoyun.com”><s:exception>ObjectNotFound</s:exception><s:message>The resource of this location does not exist</s:message></d:error>"

Does anyone know what’s wrong with my sync steps?

Check this comment:

If I understand correctly:

create a new personal sync folder in Nuts Cloud and name it “Joplin”, then fill in the webdav address of the software settings, e.g. https://dav.jianguoyun.com/dav/Joplin

1 Like

Great. It really worked! A perfect solution. Thanks a lot!!!